POJ 1385 Lifting the Stone (多邊形的重心)

Lifting the Stone

題目連接:

http://acm.hust.edu.cn/vjudge/contest/130510#problem/Gios

Description


There are many secret openings in the floor which are covered by a big heavy stone. When the stone is lifted up, a special mechanism detects this and activates poisoned arrows that are shot near the opening. The only possibility is to lift the stone very slowly and carefully. The ACM team must connect a rope to the stone and then lift it using a pulley. Moreover, the stone must be lifted all at once; no side can rise before another. So it is very important to find the centre of gravity and connect the rope exactly to that point. The stone has a polygonal shape and its height is the same throughout the whole polygonal area. Your task is to find the centre of gravity for the given polygon.
git

Input


The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer N (3 <= N <= 1000000) indicating the number of points that form the polygon. This is followed by N lines, each containing two integers Xi and Yi (|Xi|, |Yi| <= 20000). These numbers are the coordinates of the i-th point. When we connect the points in the given order, we get a polygon. You may assume that the edges never touch each other (except the neighboring ones) and that they never cross. The area of the polygon is never zero, i.e. it cannot collapse into a single line.
ide

Output


Print exactly one line for each test case. The line should contain exactly two numbers separated by one space. These numbers are the coordinates of the centre of gravity. Round the coordinates to the nearest number with exactly two digits after the decimal point (0.005 rounds up to 0.01). Note that the centre of gravity may be outside the polygon, if its shape is not convex. If there is such a case in the input data, print the centre anyway.
this

Sample Input

2
4
5 0
0 5
-5 0
0 -5
4
1 1
11 1
11 11
1 11

Sample Output

0.00 0.00
6.00 6.00

Source


2016-HUST-線下組隊賽-5
spa


題意:


求多邊形的重心.
rest


題解:


裸到爆的求重心,開場就打了,硬是最後才過掉.
坑在四捨五入時出現了-0.00的狀況致使WA... 漲姿式了,之後切記.
code


代碼:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <algorithm>
#include <vector>
#include <map>
#include <set>
#include <queue>
#define maxn 1110000
#define LL long long
#define eps 1e-8
#define inf 0x3f3f3f3f
#define mod 1000000007
#define mid(a,b) ((a+b)>>1)
#define IN freopen("in.txt","r",stdin);
using namespace std;

int n;
struct pt{
    double x,y;
}p[maxn];

double xmul(pt p0, pt p1, pt p2) {
    return (p1.x-p0.x)*(p2.y-p0.y) - (p2.x-p0.x)*(p1.y-p0.y);
}

pt center(int n) {
    pt ret = {0,0}, t;
    double t1 = 0, t2;
    for(int i=1; i<n-1; i++) {
        t2 = xmul(p[i+1],p[0],p[i]);
        t.x = (p[0].x + p[i].x + p[i+1].x) / 3.0;
        t.y = (p[0].y + p[i].y + p[i+1].y) / 3.0;
        ret.x += t.x * t2;
        ret.y += t.y * t2;
        t1 += t2;
    }

    ret.x /= t1, ret.y /= t1;
    return ret;
}

int main()
{
    //IN;

    int T; cin >> T;
    while(T--)
    {
        scanf("%d", &n);
        for(int i=0; i<n; i++) {
            scanf("%lf %lf", &p[i].x, &p[i].y);
        }

        pt ans = center(n);
        if(ans.x > -0.005 && ans.x < 0.005) ans.x = 0.0;
        if(ans.y > -0.005 && ans.y < 0.005) ans.y = 0.0;
        printf("%.2f %.2f\n", ans.x, ans.y);
    }

    return 0;
}
相關文章
相關標籤/搜索