BZOJ1969: [Ahoi2005]LANE 航線規劃(LCT)

Time Limit: 10 Sec  Memory Limit: 64 MB
Submit: 587  Solved: 259
[Submit][Status][Discuss]

Description

對Samuel星球的探險已經取得了很是巨大的成就,因而科學家們將目光投向了Samuel星球所在的星系——一個巨大的由千百萬星球構成的Samuel星系。 星際空間站的Samuel II巨型計算機通過長期探測,已經鎖定了Samuel星系中許多星球的空間座標,並對這些星球從1開始編號一、二、3……。 一些先遣飛船已經出發,在星球之間開闢探險航線。 探險航線是雙向的,例如從1號星球到3號星球開闢探險航線,那麼從3號星球到1號星球也可使用這條航線。 例以下圖所示:   在5個星球之間,有5條探險航線。 A、B兩星球之間,若是某條航線不存在,就沒法從A星球抵達B星球,咱們則稱這條航線爲關鍵航線。 顯然上圖中,1號與5號星球之間的關鍵航線有1條:即爲4-5航線。 然而,在宇宙中一些未知的磁暴和行星的衝撞,使得已有的某些航線被破壞,隨着愈來愈多的航線被破壞,探險飛船又不能及時回覆這些航線,可見兩個星球之間的關鍵航線會愈來愈多。 假設在上圖中,航線4-2(從4號星球到2號星球)被破壞。此時,1號與5號星球之間的關鍵航線就有3條:1-3,3-4,4-5。 小聯的任務是,不斷關注航線被破壞的狀況,並隨時給出兩個星球之間的關鍵航線數目。如今請你幫助完成。

Input

第一行有兩個整數N,M。表示有N個星球(1< N < 30000),初始時已經有M條航線(1 < M < 100000)。隨後有M行,每行有兩個不相同的整數A、B表示在星球A與B之間存在一條航線。接下來每行有三個整數C、A、B。C爲1表示詢問當前星球A和星球B之間有多少條關鍵航線;C爲0表示在星球A和星球B之間的航線被破壞,當後面再遇到C爲1的狀況時,表示詢問航線被破壞後,關鍵路徑的狀況,且航線破壞後不可恢復; C爲-1表示輸入文件結束,這時該行沒有A,B的值。被破壞的航線數目與詢問的次數總和不超過40000。

Output

對每一個C爲1的詢問,輸出一行一個整數表示關鍵航線數目。 注意:咱們保證不管航線如何被破壞,任意時刻任意兩個星球都可以相互到達。在整個數據中,任意兩個星球之間最多隻可能存在一條直接的航線。

Sample Input

5 5
1 2
1 3
3 4
4 5
4 2
1 1 5
0 4 2
1 5 1
-1

Sample Output

1
3

HINT

 

Source

 

時間倒流php

首先把全部的操做全都讀進來html

而後把最終形態的樹建出來,node

這樣刪邊操做就變成了加邊操做ide

維護聯通性用LCT,縮點的話用並查集維護祖先,而後暴力改祖先便可post

access操做稍微有一些改動,具體看代碼吧spa

 

 

// luogu-judger-enable-o2
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN = 1e5+10;
inline int read() {
    char c = getchar(); int x = 0, f = 1;
    while(c < '0' || c > '9') {if(c == '-') f = -1; c = getchar();}
    while(c >= '0' && c <= '9') {x = x * 10 + c - '0'; c = getchar();}
    return x * f;
}
int N, M;
int father[MAXN];
int find(int x) {
    if(father[x] == x) return father[x];
    else return father[x] = find(father[x]);
}
int unionn(int x, int y) {
    int fx = find(x), fy = find(y);
    father[fx] = fy;
}
#define ls(x) T[x].ch[0]
#define rs(x) T[x].ch[1]
#define fa(x) T[x].f
struct node {
    int f, ch[2], r, siz;
}T[MAXN];
int ident(int x) {
    return T[fa(x)].ch[0] == x ? 0 : 1;
}
void update(int x) {
    T[x].siz = T[ls(x)].siz + T[rs(x)].siz + 1;
}
void pushdown(int x) {
    if(T[x].r) {
        T[ls(x)].r ^= 1, T[rs(x)].r ^= 1;
        swap(ls(x), rs(x));
        T[x].r = 0;
    }
}
void connect(int x, int fa, int how) {
    T[x].f = fa;
    T[fa].ch[how] = x;
}
bool IsRoot(int x) {
    return T[fa(x)].ch[0] != x && T[fa(x)].ch[1] != x;
}
void rotate(int x) {
    int Y = fa(x), R = fa(Y), Yson = ident(x), Rson = ident(Y);
    int B = T[x].ch[Yson ^ 1];
    T[x].f = R;
    if(!IsRoot(Y)) connect(x, R, Rson);
    connect(B, Y, Yson);
    connect(Y, x, Yson ^ 1);
    update(Y);update(x);
}
int st[MAXN];
void splay(int x) {
    int y = x, top = 0;
    st[++top] = y;
    while(!IsRoot(y)) st[++top] = y = fa(y);
    while(top) pushdown(st[top--]);
    for(int y = fa(x); !IsRoot(x); rotate(x), y = fa(x))
        if(!IsRoot(y))
            rotate( ident(x) == ident(y) ? y : x);
}
void access(int x) {
    for(int y = 0; x;y = x, x = fa(y) = find(fa(x)))//這裏要改一下 
        splay(x), rs(x) = y, update(x);
}
void makeroot(int x) {
    access(x); splay(x);
    T[x].r ^= 1;
}
void link(int x, int y) {
    //makeroot(x);
    T[x].f = y;
}
int findroot(int x) {
    //makeroot(x);
    access(x);splay(x);
    pushdown(x);
    while(ls(x)) pushdown(x = ls(x));
    splay(x);
    return x;
}
void delet(int x, int to) {
    if(x) father[x] = to, delet(ls(x), to), delet(rs(x), to);
}
void merge(int x, int y) {
    if(x == y) return ;
    makeroot(x);
    if(findroot(y) != x) {
        link(x, y); return ;
    }
    delet(rs(x), x); rs(x) = 0;
    update(x);
}
int split(int x,int y) {
    makeroot(x);
    access(y);
    splay(y);
}
struct Edge {
    int u,v;
    bool operator < (const Edge &rhs) const{
        return u < rhs.u || (u == rhs.u && v < rhs.v);
    }
}E[MAXN];
int vis[MAXN];
struct Query {
    int opt, x, y;
}Q[MAXN];
int Qnum = 0;
int ans[MAXN];
int main() {
    #ifdef WIN32
    freopen("a.in", "r", stdin);
    #else
    //freopen("lane.in","r",stdin);
    //freopen("lane.out","w",stdout); 
    #endif
    N = read(), M = read();
    for(int i = 1; i <= N; i++) father[i] = i;
    for(int i = 1; i <= M; i++) {
        E[i].u = read(), E[i].v = read();
        if(E[i].u > E[i].v) swap(E[i].u, E[i].v);
    }
        
    sort(E + 1, E + M + 1);
    while(scanf("%d", &Q[++Qnum].opt) && Q[Qnum].opt != -1) {
        Q[Qnum].x = read(),
        Q[Qnum].y = read();
        if(Q[Qnum].x > Q[Qnum].y) swap(Q[Qnum].x, Q[Qnum].y);
        if(Q[Qnum].opt == 0)
            vis[lower_bound(E + 1, E + M + 1, (Edge){Q[Qnum].x, Q[Qnum].y} ) - E] = 1;    
    }
    Qnum--;
    for(int i = 1; i <= M; i++) 
        if(!vis[i]) 
            merge(
                    find(E[i].u), 
                    find(E[i].v)
                    );
    
    int ansnum = 0;
    for(int i = Qnum; i >= 1; i--) {
        Q[i].x = find(Q[i].x); Q[i].y = find(Q[i].y);
        if(Q[i].opt == 0) 
            merge(Q[i].x, Q[i].y);
        else 
            split(Q[i].x, Q[i].y), ans[++ansnum] = T[Q[i].y].siz - 1;  
    }
    while(ansnum) printf("%d\n", ans[ansnum--]);
    return 0;
}
相關文章
相關標籤/搜索