莫隊算法

2038: [2009國家集訓隊]小Z的襪子(hose)

Time Limit: 20 Sec  Memory Limit: 259 MB
Submit: 4471  Solved: 2049
[Submit][Status][Discuss]

Description

做爲一個生活散漫的人,小Z天天早上都要耗費好久從一堆五光十色的襪子中找出一雙來穿。終於有一天,小Z再也沒法忍受這惱人的找襪子過程,因而他決定聽天由命……
具體來講,小Z把這N只襪子從1到N編號,而後從編號L到R(L 儘管小Z並不在乎兩隻襪子是否是完整的一雙,甚至不在乎兩隻襪子是否一左一右,他卻很在乎襪子的顏色,畢竟穿兩隻不一樣色的襪子會很尷尬。
你的任務即是告訴小Z,他有多大的機率抽到兩隻顏色相同的襪子。固然,小Z但願這個機率儘可能高,因此他可能會詢問多個(L,R)以方便本身選擇。
php

Input

輸入文件第一行包含兩個正整數N和M。N爲襪子的數量,M爲小Z所提的詢問的數量。接下來一行包含N個正整數Ci,其中Ci表示第i只襪子的顏色,相同的顏色用相同的數字表示。再接下來M行,每行兩個正整數L,R表示一個詢問。spa

Output

包含M行,對於每一個詢問在一行中輸出分數A/B表示從該詢問的區間[L,R]中隨機抽出兩隻襪子顏色相同的機率。若該機率爲0則輸出0/1,不然輸出的A/B必須爲最簡分數。(詳見樣例)blog

Sample Input

6 4
1 2 3 3 3 2
2 6
1 3
3 5
1 6

Sample Output

2/5
0/1
1/1
4/15
【樣例解釋】
詢問1:共C(5,2)=10種可能,其中抽出兩個2有1種可能,抽出兩個3有3種可能,機率爲(1+3)/10=4/10=2/5。
詢問2:共C(3,2)=3種可能,沒法抽到顏色相同的襪子,機率爲0/3=0/1。
詢問3:共C(3,2)=3種可能,均爲抽出兩個3,機率爲3/3=1/1。
注:上述C(a, b)表示組合數,組合數C(a, b)等價於在a個不一樣的物品中選取b個的選取方案數。
【數據規模和約定】
30%的數據中 N,M ≤ 5000;
60%的數據中 N,M ≤ 25000;
100%的數據中 N,M ≤ 50000,1 ≤ L < R ≤ N,Ci ≤ N。
 
題目連接:傳送門
 
AC代碼:
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;
const int N = 50000 + 5;
typedef long long ll;

ll s[N], ans;

int n, m, l, block;

int co[N], cnt[N], pos[N];

ll choose(ll x) {return x * (x - 1)/ 2;}

ll gcd(ll a, ll b){return b == 0 ? a : gcd(b, a%b);}

struct query{
    int l, r, id;
    ll ans, tol;
    bool operator < (const query a)const{
        if(pos[l] == pos[a.l]) return r < a.r;
        return l < a.l;
    }
}q[N];

bool cmp(query a, query b)  {return a.id < b.id;}

void update(int x, int add){
    ans -= choose(1ll * cnt[co[x]]);
    cnt[co[x]] += add;
    ans += choose(1ll * cnt[co[x]]);
}

void work(){
    sort(q, q + m);
    ans = 0;
    memset(cnt, 0, sizeof(cnt));
    //for(int i = 0; i < m; i++) printf("l = %d, r = %d\n", q[i].l, q[i].r);
    for(int i = 0, l = 1, r = 0; i < m; i ++){
        while(r < q[i].r) r += 1,update(r, 1);
        while(r > q[i].r) r -= 1,update(r + 1, -1);
        while(l < q[i].l) l += 1,update(l - 1, -1);
        while(l > q[i].l) l -= 1,update(l, 1);
        //printf("l = %d, r = %d\n", l, r);
        //for(int i = 1; i <= n; i ++)printf("cnt[%d] = %d\n", i, cnt[i]);
        if(l == q[i].l && q[i].r == r) q[i].ans = ans;
    }
    sort(q, q + m, cmp);
    for(int i = 0; i < m; i ++){
        if(q[i].ans == 0) {
            puts("0/1");
            continue;
        }
        int GCD = gcd(q[i].ans, q[i].tol);
        printf("%lld/%lld\n", q[i].ans/GCD, q[i].tol/GCD);
    }
}

int main(){
    while(scanf("%d%d", &n, &m) == 2){
        block = (int) sqrt(n);
        for(int i = 1; i <=  n; i ++) pos[i] = (i - 1)/block + 1;
        for(int i = 1; i <= n; i ++)    scanf("%d", co + i);
        for(int i = 0; i < m; i ++){
            scanf("%d%d", &q[i].l, &q[i].r);
            q[i].id = i;
            q[i].tol = choose(1ll * (q[i].r - q[i].l + 1));
        }
        work();
    }
    return 0;
}
相關文章
相關標籤/搜索