poj 1979 Red and Black

地址 http://poj.org/problem?id=1979ios

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output

45
59
6
13

大概意思就是 @是一我的的起點 能夠在.的地板磚上移動 可是不能移動到#的地板上。求可以達到的最多地板
算是基礎的dfs題目 沒有剪枝 就是遍歷app

代碼spa

#include <iostream>




using namespace std;


int n,m;

const int N = 500;

char graph[N][N];

char visit[N][N];
int ret = 0;

int addx[] = { 1,-1,0,0 };
int addy[] = { 0,0,1,-1 };


void Dfs(int x, int y) {
    if (x < 0 || x >= n || y < 0 || y >= m) return;

    if (visit[x][y] == 1  || graph[x][y] == '#') return;

    visit[x][y] = 1;
    if (graph[x][y] == '.') {
        //cout << "x = " << x << ".   y = " << y << endl;
        ret++;
    }

    for (int i = 0; i < 4; i++) {
        int newx = x + addx[i];
        int newy = y + addy[i];
        Dfs(newx, newy);
    }

    return;
}


int main()
{
    while (cin >> m >> n) {
        if (m == 0 || n == 0) break;
        int x, y; 
        ret = 0;
        memset(visit, 0, N*N);

        for (int i = 0; i < n; i++) {
            for (int j = 0; j < m; j++) {
                cin >> graph[i][j];
                if (graph[i][j] == '@') {
                    x = i; y = j;
                    ret++;
                }
            }
        }

        Dfs(x, y);

        cout << ret << endl;
    }
    
    //system("pause");

    return 0;
}
相關文章
相關標籤/搜索