R1
|
RIP
|
R2
|
EIGRP
|
R3
R1#show running-config
!
hostname R1
interface Loopback0
ip address 10.0.0.1 255.0.0.0
!
interface Serial1/1
ip address 20.0.0.1 255.0.0.0
serial restart-delay 0
!
router rip
network 10.0.0.0
network 20.0.0.0
default-information originate
!
ip route 0.0.0.0 0.0.0.0 20.0.0.2
no ip http server
no ip http secure-server
!
R2#show running-config
hostname R2
!
interface Serial1/0
ip address 20.0.0.2 255.0.0.0
serial restart-delay 0
!
interface Serial1/1
ip address 30.0.0.1 255.0.0.0
serial restart-delay 0
!
router eigrp 90
network 20.0.0.0
network 30.0.0.0
auto-summary
!
ip default-network 20.0.0.0
ip route 0.0.0.0 0.0.0.0 20.0.0.1
no ip http server
no ip http secure-server
!
R3#show running-config
!
hostname R3
!
interface Loopback0
ip address 40.0.0.1 255.0.0.0
!
interface Serial1/0
ip address 30.0.0.2 255.0.0.0
serial restart-delay 0
!
router eigrp 90
network 30.0.0.0
network 40.0.0.0
auto-summary
R1#show ip rou
Gateway of last resort is 20.0.0.2 to network 0.0.0.0
C 20.0.0.0/8 is directly connected, Serial1/1
C 10.0.0.0/8 is directly connected, Loopback0
S* 0.0.0.0/0 [1/0] via 20.0.0.2
R2#show ip rou
Gateway of last resort is 20.0.0.1 to network 0.0.0.0
C* 20.0.0.0/8 is directly connected, Serial1/0
D 40.0.0.0/8 [90/2297856] via 30.0.0.2, 00:00:48, Serial1/1
C 30.0.0.0/8 is directly connected, Serial1/1
S* 0.0.0.0/0 [1/0] via 20.0.0.1
R3#show ip rou
Gateway of last resort is 30.0.0.1 to network 20.0.0.0
D* 20.0.0.0/8 [90/2681856] via 30.0.0.1, 00:01:04, Serial1/0 C 40.0.0.0/8 is directly connected, Loopback0 C 30.0.0.0/8 is directly connected, Serial1/0