-----R1----------R2----------R3----
RIP EIGRP
R1#show running-config
hostname R1
!
interface FastEthernet0/0
ip address 10.0.0.1 255.0.0.0
duplex half
!
interface Serial1/1
ip address 20.0.0.1 255.0.0.0
serial restart-delay 0
!
router rip
network 10.0.0.0
network 20.0.0.0
R2#show running-config
hostname R2
!
interface Serial1/0
ip address 20.0.0.2 255.0.0.0
serial restart-delay 0
!
interface Serial1/1
ip address 30.0.0.1 255.0.0.0
serial restart-delay 0
!
!
router eigrp 90
redistribute rip metric 100 100 100 100 100
network 30.0.0.0
auto-summary
!
router rip
redistribute eigrp 90 metric 5
network 20.0.0.0
R3#show running-config ! hostname R3 ! interface FastEthernet0/0 ip address 40.0.0.1 255.0.0.0 duplex half ! interface Serial1/0 ip address 30.0.0.2 255.0.0.0 serial restart-delay 0 ! router eigrp 90 network 30.0.0.0 network 40.0.0.0 auto-summary