poj 1325 Machine Schedule

第三道二分圖 匈牙利算法 算法

Machine Schedule

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 10860 Accepted: 4611

Description ide

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem. 

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, ..., mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, ... , mode_m-1. At the beginning they are both work at mode_0. 

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y. 

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines. 

Input ui

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y. 

The input will be terminated by a line containing a single zero. 

Output this

The output should be one integer per line, which means the minimal times of restarting machine.

Sample Input spa

5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0

Sample Output .net

3

Source rest

[Submit]   [Go Back]   [Status]   [Discuss] code

個人解答:

/*=============================================================================
#     FileName: 1325.cpp
#         Desc: poj 1325
#       Author: zhuting
#        Email: cnjs.zhuting@gmail.com
#     HomePage: my.oschina.net/locusxt
#      Version: 0.0.1
#    CreatTime: 2013-12-07 18:54:34
#   LastChange: 2013-12-07 18:54:34
#      History:
=============================================================================*/
#include <cstdio>
#include <cstdlib>
#include <string>
#include <cstring>
#include <algorithm>
#define maxn 105


int n = 0, m = 0, k = 0;

bool mymap[maxn][maxn] = {0};
bool cover[maxn] = {0};
int link_[maxn] = {0};

bool find(int x)
{
	for (int i = 0; i < m; ++i)
	{
		if (!cover[i] && mymap[x][i])
		{
			cover[i] = 1;
			if (link_[i] == -1 || find(link_[i]))
			{
				link_[i] = x;
				return 1;
			}
		}
	}
	return 0;
}

void init()
{
	memset(mymap, 0, sizeof(mymap));
	memset(cover, 0, sizeof(cover));
	memset(link_, 0xff, sizeof(link_));
	return;
}

int main()
{
	int tmp = 0, x = 0, y = 0;
	while (scanf("%d", &n) && n)
	{
		int ans = 0;
		init();
		scanf("%d%d", &m, &k);
		for (int i = 0; i < k; ++i)
		{
			scanf("%d%d%d", &tmp, &x, &y);
			if (x && y)/*等於0的不用算,一開始處在mode0*/
				mymap[x - 1][y - 1] = 1;
		}
		for (int i = 0; i < n; ++i)
		{
			memset(cover, 0, sizeof(cover));
			if (find(i)) ++ans;
		}
		printf("%d\n", ans);
	}
	return 0;
}
相關文章
相關標籤/搜索