Machine Schedule
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 17457 |
|
Accepted: 7328 |
Descriptionnode
As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.
There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, ..., mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, ... , mode_m-1. At the beginning they are both work at mode_0.
For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.
Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.
Inputios
The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.
The input will be terminated by a line containing a single zero.
Outputc++
The output should be one integer per line, which means the minimal times of restarting machine.
Sample Inputide
5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0
Sample Outputui
3
Sourcethis
解析:
不知道這題我爲何沒想出來怎麼建邊。。。菜死我算了 emm。。
就是求最小點集覆蓋
匈牙利便可 這裏用的dinic
#include <iostream>
#include <cstdio>
#include <sstream>
#include <cstring>
#include <map>
#include <cctype>
#include <set>
#include <vector>
#include <stack>
#include <queue>
#include <algorithm>
#include <cmath>
#include <bitset>
#define rap(i, a, n) for(int i=a; i<=n; i++)
#define rep(i, a, n) for(int i=a; i<n; i++)
#define lap(i, a, n) for(int i=n; i>=a; i--)
#define lep(i, a, n) for(int i=n; i>a; i--)
#define rd(a) scanf("%d", &a)
#define rlld(a) scanf("%lld", &a)
#define rc(a) scanf("%c", &a)
#define rs(a) scanf("%s", a)
#define rb(a) scanf("%lf", &a)
#define rf(a) scanf("%f", &a)
#define pd(a) printf("%d\n", a)
#define plld(a) printf("%lld\n", a)
#define pc(a) printf("%c\n", a)
#define ps(a) printf("%s\n", a)
#define MOD 2018
#define LL long long
#define ULL unsigned long long
#define Pair pair<int, int>
#define mem(a, b) memset(a, b, sizeof(a))
#define _ ios_base::sync_with_stdio(0),cin.tie(0)
//freopen("1.txt", "r", stdin);
using namespace std;
const int maxn = 1e5 + 10, INF = 0x7fffffff;
int n, m, s, t, k;
int head[maxn], cur[maxn], d[maxn], vis[maxn], cnt;
int nex[maxn << 1];
struct node
{
int u, v, c;
}Node[maxn << 1];
void add_(int u, int v, int c)
{
Node[cnt].u = u;
Node[cnt].v = v;
Node[cnt].c = c;
nex[cnt] = head[u];
head[u] = cnt++;
}
void add(int u, int v, int c)
{
add_(u, v, c);
add_(v, u, 0);
}
bool bfs()
{
queue<int> Q;
mem(d, 0);
d[s] = 1;
Q.push(s);
while(!Q.empty())
{
int u = Q.front(); Q.pop();
for(int i = head[u]; i != -1; i = nex[i])
{
int v = Node[i].v;
if(!d[v] && Node[i].c > 0)
{
d[v] = d[u] + 1;
Q.push(v);
if(v == t) return 1;
}
}
}
return d[t] != 0;
}
int dfs(int u, int cap)
{
int ret = 0;
if(u == t || cap == 0)
return cap;
for(int &i = cur[u]; i != -1; i = nex[i])
{
int v = Node[i].v;
if(d[v] == d[u] + 1 && Node[i].c > 0)
{
int V = dfs(v, min(cap, Node[i].c));
Node[i].c -= V;
Node[i ^ 1].c += V;
ret += V;
cap -= V;
if(cap == 0) break;
}
}
if(cap > 0) d[u] = -1;
return ret;
}
int Dinic(int u)
{
int ans = 0;
while(bfs())
{
memcpy(cur, head, sizeof(head));
ans += dfs(u, INF);
}
return ans;
}
int main()
{
while(scanf("%d", &n) != EOF && n)
{
rd(m), rd(k);
int a, b, c;
mem(head, -1);
cnt = 0;
s = 0, t = n + m + 1;
rap(i, 1, k)
{
rd(a), rd(b), rd(c);
b++, c++;
if(b != 1 && c != 1)
add(b, n + c, 1);
}
rap(i, 1, n)
add(s, i, 1);
rap(i, 1, m)
add(n + i, t, 1);
cout << Dinic(s) << endl;
}
return 0;
}
Machine Schedule
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 17457 |
|
Accepted: 7328 |
Descriptionspa
As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.
There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, ..., mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, ... , mode_m-1. At the beginning they are both work at mode_0.
For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.
Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.
Inputrest
The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.
The input will be terminated by a line containing a single zero.
Outputxml
The output should be one integer per line, which means the minimal times of restarting machine.
Sample Inputthree
5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0
Sample Output
3
Source
本身選擇的路,跪着也要走完。朋友們,雖然這個世界日益浮躁起來,只要可以爲了當時純粹的夢想和感動堅持努力下去,無論其它人怎麼樣,咱們也可以保持本身的本色走下去。