稀疏圖斷定

稀疏圖斷定

Descriptionios

輸入一個有向圖,判斷這個圖是否是一個稀疏圖。c++

這裏咱們定義,若是一個圖的邊數小於等於點數的 10 倍,咱們稱這個圖爲稀疏圖,不然,這個圖是稠密圖。spa

Inputcode

輸入第一行一個整數 n(1 <= n <= 100) 表示圖的點數。ip

接下里 n 行,每行輸入 n 個 0 或者 1 的整數,表示這個圖的鄰接矩陣。ci

注意,可能存在自環,可是不算邊數。it

Outputio

若是輸入的圖是一個稀疏圖,輸出"Yes",不然輸出"No"。stream

Sample Input 1基礎

5
0 0 1 1 0
1 0 1 0 0
1 1 0 0 1
0 0 0 0 0
1 1 1 1 0
Sample Output 1

Yes
Sample Input 2

12
1 1 1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1 1 1
Sample Output 2

No
——摘自YCOJ
圖和樹基礎。
這道題比較簡單,不須要過多的考慮,先提供一個,嗯,不須要思考的程序。(僞代碼,請勿參考)

#include<bits/stdc++.h>
using namespace std;
int a[1000][1000];
int main(){
	int n;
	cin >> n;
	if(n*10>=n*n){
		cout << "Yes";
	}else{
		cout << "No";
	}
	return 0;
}

嗯,沒錯,超級蒟蒻的代碼,但爲何不會全對,請注意「自環」這個詞。
一條邊的起點終點同爲一個點即爲「自環」。
附贈AC代碼:

#include<iostream>
using namespace std;
int n;
int a[100][100];
int main(){
	cin >> n ;
	int ans = 0;
    for(int i=1;i<=n;i++){
    	for(int j=1;j<=n;j++){
    		cin >> a[i][j];
		}
	}
	for(int i=0;i<n;i++){
	for(int j=0;j<n;j++){
      if(i!=j){
		ans+=a[i][j];
      }
    }
    }
if(ans<=n*10){
	cout<<"Yes"<<endl;
}else{
	cout<<"No"<<endl;
}
	return 0;
}
相關文章
相關標籤/搜索