shtml
系統版本: macOS 10.14.4 (18E226)
內核版本: Darwin 18.5.0
型號名稱: Mac mini 2014
型號標識符: Macmini7,1
處理器名稱: Intel Core i5
處理器速度: 2.8 GHz
處理器數目: 1
核總數: 2
L2 緩存(每一個核): 256 KB
L3 緩存: 3 MB
內存: 8 GB
Boot ROM 版本: 238.0.0.0.0
SMC 版本(系統): 2.24f32
序列號(系統): C07WN0Z0G1J2
硬件 UUID: 53859791-F72D-5683-AE50-C9F0380BDB19
mac下啓動ssh服務緩存
https://www.cnblogs.com/liyuanhong/articles/6540106.html服務器
mac自己安裝了ssh服務,默認狀況下不會開機自啓
1.啓動sshd服務:
sudo launchctl load -w /System/Library/LaunchDaemons/ssh.plist
2.中止sshd服務:
sudo launchctl unload -w /System/Library/LaunchDaemons/ssh.plist
3查看是否啓動:
sudo launchctl list | grep ssh
若是看到下面的輸出表示成功啓動了:
--------------
- 0 com.openssh.sshd
官方開啓 ssh root 用戶的說明app
https://support.apple.com/zh-cn/HT204012ssh
# 1. 先進入 root 用戶模式
su
# 2. 而後編輯 sshd_config 文件內容
vi /private/etc/ssh/sshd_config
# 3. 找到‘#PermitRootLogin prohibit-password’這一行,把前面的 # 號去掉,並把後面改爲 yes
PermitRootLogin yes
# 4. 保存並退出
:wq!
5.重啓 sshd 服務
launchctl stop com.openssh.sshd # 中止 ssh 服務
launchctl start com.openssh.sshd #啓動 ssh 服務
ssh免密碼登錄及其原理加密
https://www.cnblogs.com/kex1n/p/6017963.htmlspa
如何生成密鑰:
一、在客戶端打開終端,執行ssh-keygen,該命令會默認在~/.ssh/目錄下建立id_rsa、id_rsa.pub兩個文件,分別爲您的公鑰和私鑰。
二、將公鑰id_rsa.pub文件拷貝到服務器端的~/.ssh/authorized_keys文件中,有三種方法:
經過scp拷貝:
例:scp -P 22 ~/.ssh/id_rsa.pub user@host:~/authorized_keys #可選參數-P表明指定用端口號22
經過ssh-copyid程序:
例:ssh-copy-id user@host #此種方式簡單,不需追加改文件名,但不能指定端口號,默認以22端口
經過cat方法:
例:cat ~/.ssh/id_rsa.pub | ssh -p 22 user@host ‘cat >> ~/.ssh/authorized_keys’code
免密碼登陸原理server
圖解,server A免登陸到server B:
1.在A上生成公鑰私鑰。
2.將公鑰拷貝給server B,要重命名成authorized_keys(從英文名就知道含義了)
3.Server A向Server B發送一個鏈接請求。
4.Server B獲得Server A的信息後,在authorized_key中查找,若是有相應的用戶名和IP,則隨機生成一個字符串,並用Server A的公鑰加密,發送給Server A。
5.Server A獲得Server B發來的消息後,使用私鑰進行解密,而後將解密後的字符串發送給Server B。Server B進行和生成的對比,若是一致,則容許免登陸。
總之:A要免密碼登陸到B,B首先要擁有A的公鑰,而後B要作一次加密驗證。對於非對稱加密,公鑰加密的密文不能公鑰解開,只能私鑰解開。htm
end