PAT 甲級 1039 Course List for Student (25 分)(字符串哈希,優先隊列,沒想到是哈希)*

1039 Course List for Student (25 分)
 

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.html

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤), the number of students who look for their course lists, and K (≤), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni​​ (≤) are given in a line. Then in the next line, Ni​​ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.ios

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.git

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0
做者: CHEN, Yue
單位: 浙江大學
時間限制: 600 ms
內存限制: 64 MB

 

題意:算法

  浙江大學有40000名在校生,2500門課,給一張課程登記表,上面有K個課程,每門課分別有Ni個學生選,經過這張選課登記表統計出每一個學生的申報的課程,分別有N個學生要查詢他們的選課信息。其中,課程編號0~K-1,學生編號用3個大寫英語字母和1個數字進行編號。
api

題解:數組

 

  直接用map最後一個測試內存超限:23/25,一開始數組內存超限,改用優先隊列仍是超限,實在無奈查題解,原來要用字符串哈希。在很是大的數據下的確是須要嚴謹的哈希算法。沒學過字符串哈希,第一次,要記住了。這題用map來實現學生姓名和學生編號之間的映射會超時,所以須要用字符串hash求解。讀取每門課的全部選課學生,而後將該課程編號加到全部選了這門課的學生裏面。ide

int getID(char name[]) {
    int id = 0;
    for(int i = 0; i < 3; i++) {
        id = id * 26 + (name[i] - 'A');
    }
    id = id * 10 + (name[3] - '0');
    return id;
}

  咱們這裏考慮使用哈希表,麻煩的是,學生的名稱是英文字母+數字的組合,沒法直接做爲數組的索引。但好在學生的名稱是有規律的,3位英文字母能夠看做一個26進制數,最後一位是10進制,這種進制混編方式可以保證每個學生都有一個惟一的id。咱們根據根據這種思路把char*類型的name轉換成int型的id,而後這個id就能夠做爲每一個學生惟一的標識。
  申請26 * 26 * 26 * 10個vector(而不是40000個,轉換空間須要),id做爲學生的查找索引,那麼每一個vector便變成了學生的課程記錄,直接排序便可。測試

 

AC代碼:flex

#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<map>
#include<string>
#include<cstring>
using namespace std;
#define MAX_STUDENT 26*26*26*10
struct cmp
{
    bool operator()(int x,int y)
    {
        return x>y;
    }
};
priority_queue<int,vector<int>,cmp>q[MAX_STUDENT];
int getID(char name[]) {
    int id = 0;
    for(int i = 0; i < 3; i++) {
        id = id * 26 + (name[i] - 'A');
    }
    id = id * 10 + (name[3] - '0');
    return id;
}
int n,m;
char name[6];
int k;
int main()
{
    cin>>n>>m;
    for(int i=1;i<=m;i++){
        int cla,num;
        cin>>cla>>num;
        for(int j=1;j<=num;j++){        
            cin>>name;
            k=getID(name);
            q[k].push(cla);
        }
    }
    for(int i=1;i<=n;i++){
        cin>>name;
        k=getID(name);
        cout<<name<<" "<<q[k].size();
        while(!q[k].empty()){
            cout<<" "<<q[k].top();
            q[k].pop();
        }
        cout<<endl;
    }
    return 0;
 } 
相關文章
相關標籤/搜索