|
命令
|
目的
|
Step 1
|
configure terminal
|
進入配置狀態
|
Step 2
|
interface range {
port-range}
|
進入組配置狀態
|
Step 3
|
|
可使用平時的端口配置命令進行配置
|
Step 4
|
end
|
退回
|
Step 5
|
show interfaces [
interface-id]
|
驗證配置
|
Step 6
|
copy running-config startup-config
|
保存
|
|
Switch# configure terminal
Switch(config)# interface range fastethernet0/1 - 5
Switch(config-if-range)# no shutdown
Switch(config-if-range)#
*Oct 6 08:24:35: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
*Oct 6 08:24:35: %LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to up
*Oct 6 08:24:35: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to up
*Oct 6 08:24:35: %LINK-3-UPDOWN: Interface FastEthernet0/4, changed state to up
*Oct 6 08:24:35: %LINK-3-UPDOWN: Interface FastEthernet0/5, changed state to up
*Oct 6 08:24:36: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/05,
changed state to up
*Oct 6 08:24:36: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed
state to up
*Oct 6 08:24:36: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed
state to up
Switch# configure terminal
Switch(config)# interface range fastethernet0/1 - 3, gigabitethernet0/1 - 2
Switch(config-if-range)# no shutdown
Switch(config-if-range)#
*Oct 6 08:29:28: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
*Oct 6 08:29:28: %LINK-3-UPDOWN: Interface FastEthernet0/2, changed state to up
*Oct 6 08:29:28: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state to up
*Oct 6 08:29:28: %LINK-3-UPDOWN: Interface GigabitEthernet0/1, changed state to up
*Oct 6 08:29:28: %LINK-3-UPDOWN: Interface GigabitEthernet0/2, changed state to up
*Oct 6 08:29:29: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/ 1,
changed state to up
*Oct 6 08:29:29: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/ 2,
changed state to up
*Oct 6 08:29:29: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/ 3,
changed state to up
|
命令
|
目的
|
Step 1
|
configure terminal
|
進入配置狀態.
|
Step 2
|
interface
interface-id
|
進入端口配置狀態.
|
Step 3
|
speed {10 | 100 | 1000 | auto | nonegotiate}web |
設置端口速率
注
1000 只工做在千兆口. GBIC模塊只工做在1000 Mbps下.
nonegotiate 只能在這些GBIC上用 1000BASE-SX, -LX, and -ZX GBIC.
|
Step 4
|
duplex {auto | full | half}安全 |
設置全雙工或半雙工.
|
Step 5
|
end
|
退出
|
Step 6
|
show interfaces
interface-id
|
顯示有關配置狀況
|
Step 7
|
copy running-config startup-config
|
保存
|
Switch# configure terminal
Switch(config)# interface fastethernet0/3
Switch(config-if)# speed 10
Switch(config-if)# duplex half
|
命令
|
目的
|
Step 1
|
configure terminal
|
進入配置模式
|
Step 2
|
interface
interface-id
|
進入要加入描述的端口
|
Step 3
|
description
string
|
加入描述 (最多240個字符).
|
Step 4
|
end
|
退回.
|
Step 5
|
show interfaces
interface-id
description
or
show running-config
|
驗證.
|
Step 6
|
copy running-config startup-config
|
保存
|
|
Use the no description interface configuration command to delete the description.服務器
This example shows how to add a description on Fast Ethernet interface 0/4 and to verify the description:網絡
Switch# config terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface fastethernet0/4
Switch(config-if)# description Connects to Marketing
Switch(config-if)# end
Switch# show interfaces fastethernet0/4 description
Interface Status Protocol Description
Fa0/4 up down Connects to Marketing
Show Commands for Interfaces
Command
|
目的
|
show interfaces [
interface-id]
|
顯示全部端口或某一端口的狀態和配置.
|
show interfaces
interface-id
status [
err-disabled]
|
顯示一系列端口的狀態或錯誤-關閉的狀態
|
show interfaces [
interface-id]
switchport
|
顯示二層端口的狀態,能夠用來決定此口是否爲二層或三層口。
|
show interfaces [
interface-id]
description
|
顯示端口描述
|
show running-config interface [
interface-id]
|
顯示當前配置中的端口配置狀況
|
show version
|
顯示軟硬件等狀況
|
|
Switch# show interfaces status
Port Name Status Vlan Duplex Speed Type
Gi0/1 connected routed a-full a-100 10/100/1000Base
TX
Gi0/2 wce server 20.20.2 disabled routed auto auto 10/100/1000Base TX
Gi0/3 ip wccp web-cache notconnect routed auto auto 10/100/1000Base TX
Gi0/4 notconnect routed auto auto 10/100/1000Base TX
Gi0/5 notconnect routed auto auto 10/100/1000Base TX
Gi0/6 disabled routed auto auto 10/100/1000Base TX
Gi0/7 disabled routed auto auto 10/100/1000Base TX
Gi0/8 disabled routed auto 100 10/100/1000Base TX
Gi0/9 notconnect routed auto auto 10/100/1000Base TX
Gi0/10 notconnect routed auto auto 10/100/1000Base TX
Gi0/11 disabled routed auto auto unknown
Gi0/12 notconnect routed auto auto unknown
Switch# show interfaces fastethernet 0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative Mode: static access
Operational Mode: down
Administrative Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Voice VLAN: dot1p (Inactive)
Appliance trust: 5
Switch# show running-config interface fastethernet0/2
Building configuration...
Current configuration : 131 bytes
!
interface FastEthernet0/2
switchport mode access
switchport protected
no ip address
mls qos cos 7
mls qos cos override
end
Clear
命令
|
目的
|
clear counters [
interface-id]
|
清除端口計數器.
|
clear line [number | console 0 | vty number]負載均衡 |
重置異步串口的硬件邏輯
|
![]() |
Note clear counters 命令只清除用show interface所顯示的計數,不影響用snmp獲得的計數dom |
Switch# clear counters fastethernet0/5
Clear "show interface" counters on this interface [confirm] y
Switch#
*Sep 30 08:42:55: %CLEAR-5-COUNTERS: Clear counter on interface FastEthernet0/5
by vty1 (171.69.115.10)
Switch# clear interface fastethernet0/5
|
命令
|
目的
|
Step 1
|
configure terminal
|
進入配置狀態
|
Step 2
|
interface {vlan vlan-id} | {{fastethernet | gigabitethernet} interface-id} | {port-channel port-channel-number}異步 |
選擇要關閉的端口
|
Step 3
|
shutdown
|
關閉
|
Step 4
|
end
|
退出
|
Step 5
|
show running-config
|
驗證
|
|
Switch# configure terminal
Switch(config)# interface fastethernet0/5
Switch(config-if)# shutdown
Switch(config-if)#
*Sep 30 08:33:47: %LINK-5-CHANGED: Interface FastEthernet0/5, changed state to a
administratively down
Switch# configure terminal
Switch(config)# interface fastethernet0/5
Switch(config-if)# no shutdown
Switch(config-if)#
*Sep 30 08:36:00: %LINK-3-UPDOWN: Interface FastEthernet0/5, changed state to up
VLAN做爲邏輯定義的網絡示意圖ide
Catalyst 3550交換機支持250個 VLAN,能夠分別是VTP client, server, 及 transparent modes. VLAN號能夠從1到4094. VLAN號1002到1005保留給令牌環及FDDI VLAN. VTP只能學習到普通範圍的VLAN, 即從VLAN到1到1005; VLAN號大於1005屬於擴展VLAN,不存在VLAN數據庫中。 交換機必須配置成VTP透明模式當須要生成VLAN 號從1006到4094.學習
本交換機支持基於每一VLAN的生成樹(PVST),最多支持128個生成樹。本交換機支持ISL及IEEE 802.1Q trunk二種封裝。ui
![]() |
注意 不要手工刪除
vlan.dat 文件,可能形成VLAN的不完整。 如要刪除vlan須要用有關的命令來進行
|
|
命令
|
目的
|
Step 1
|
configure terminal
|
進入配置狀態
|
Step 2
|
vlan
vlan-id
|
輸入一個VLAN號, 而後進入vlan配置狀態,能夠輸入一個新的VLAN號或舊的來進行修改。
|
Step 3
|
name
vlan-name
|
(可選)輸入一個VLAN名,若是沒有配置VLAN名,缺省的名字是VLAN號前面用0填滿的4位數,如VLAN0004是VLAN4的缺省名字
|
Step 4
|
mtu
mtu-size
|
(可選) 改變MTU大小
|
Step 5
|
end
|
退出
|
Step 6
|
show vlan {name vlan-name | id vlan-id} |
驗證
|
Step 7
|
copy running-config startup config
|
(可選) 保存配置
|
用no vlan name 或 no vlan mtu 退回到缺省的vlan配置狀態
Switch# configure terminal
Switch(config)# vlan 20
Switch(config-vlan)# name test20
Switch(config-vlan)# end
|
命令
|
目的
|
Step 1
|
vlan database
|
進入VLAN配置狀態
|
Step 2
|
vlan
vlan-id
name
vlan-name
|
加入VLAN號及VLAN名
|
Step 3
|
vlan vlan-id mtu mtu-size |
(可選) 修改MTU大小
|
Step 4
|
exit
|
更新VLAN數據庫並退出
|
Step 5
|
show vlan {name vlan-name | id vlan-id} |
驗證配置
|
Step 6
|
copy running-config startup config
|
保存配置(可選)
|
|
Switch# vlan database
Switch(vlan)# vlan 20 name test20
Switch(vlan)# exit
APPLY completed.
Exiting....
Switch#
![]() |
注意 當刪除一個VLAN時,原來屬於此VLAN的端口將處於非激活的狀態,直到將其分配給某一VLAN。
|
|
命令
|
目的
|
Step 1
|
configure terminal
|
進入配置狀態
|
Step 2
|
no vlan
vlan-id
|
刪除某一VLAN.
|
Step 3
|
end
|
退出
|
Step 4
|
show vlan brief
|
驗證
|
Step 5
|
copy running-config startup config
|
保存
|
|
|
命令
|
目的
|
Step 1
|
configure terminal
|
進入配置狀態
|
Step 2
|
interface
interface-id
|
進入要分配的端口
|
Step 3
|
switchport mode access
|
定義二層口
|
Step 4
|
switchport access vlan
vlan-id
|
把端口分配給某一VLAN
|
Step 5
|
end
|
退出
|
Step 6
|
show running-config interface
interface-id
|
驗證端口的VLAN號
|
Step 7
|
show interfaces
interface-id
switchport
|
驗證端口的管理模式和VLAN狀況
|
Step 8
|
copy running-config startup-config
|
保存配置
|
|
使用 default interface interface-id還原到缺省配置狀態。
Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface fastethernet0/1
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 2
Switch(config-if)# end
Switch#
|
命令
|
目的
|
Step 1
|
configure terminal
|
進入配置狀態
|
Step 2
|
interface
interface-id
|
進入端口配置狀態
|
Step 3
|
switchport mode {dynamic {auto | desirable} | trunk} |
配置二層trunk模式。
|
Step 4
|
switchport access vlan
vlan-id
|
(可選) 指定一個缺省VLAN, 若是此端口再也不是trunk
|
Step 5
|
switchport trunk native vlan
vlan-id
|
指定802.1Q native VLAN號
|
Step 6
|
end
|
退出
|
Step 7
|
show interfaces
interface-id
switchport
|
顯示有關switchport 的配置
|
Step 8
|
show interfaces
interface-id
trunk
|
顯示有關trunk的配置
|
Step 9
|
copy running-config startup-config
|
保存配置
|
Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface fastethernet0/4
Switch(config-if)# switchport mode trunk
Switch(config-if)# end
|
Command
|
Purpose
|
Step 1
|
configure terminal
|
進入配置狀態
|
Step 2
|
interface
interface-id
|
進入端口配置
|
Step 3
|
switchport mode trunk
|
配置二層口爲trunk
|
Step 4
|
switchport trunk allowed vlan {add | all | except | remove} vlan-list |
(可選) 配置trunk容許的VLAN.
使用
add,
all,
except,
remove
關健字
|
Step 5
|
end
|
退出
|
Step 6
|
show interfaces
interface-id
switchport
|
驗證VLAN配置狀況.
|
Step 7
|
copy running-config startup-config
|
保存配置
|
|
Switch(config)# interface fastethernet0/1
Switch(config-if)# switchport trunk allowed vlan remove 2
Switch(config-if)# end
|
命令
|
目的
|
Step 1
|
configure terminal
|
進入配置狀態
|
Step 2
|
interface
interface-id
|
進入配置成802.1qtrunk的端口
|
Step 3
|
switchport trunk native vlan
vlan-id
|
配置native VLAN號
|
Step 4
|
end
|
退出
|
Step 5
|
show interfaces interface-id switchport |
驗證native VLAN配置
|
Step 6
|
copy running-config startup-config
|
保存配置
|
|
負載均衡可使用流量分流到其它平行的trunks上去. 交換機爲了不環路, STP一般是阻斷全部端×××換機之間只留一條鏈路 。使用負載均衡後, 能夠把不一樣VLAN的流量分配到不一樣的trunk上。
當同一臺交換機的二個口造成環路時, STP端口權值用來決定那個口是enable的,那個口是阻斷的。 能夠經過配置端口權值來決定二對trunk各走那些VLAN, 有較高權值的端口(數字較小的)vlan, 將處於轉發狀態,同一個VLAN在另外一個trunk有較低的權值(數字較大)則將處在阻斷狀態。 即同一VLAN只在一個trunk上發送接受。
基於端口權值的負載均衡示意圖
trunk1將發送和接收VLAN8-10的數據,trunk2將發送和接收VLAN3-6的數據
|
Command
|
Purpose
|
Step 1
|
configure terminal
|
進入Switch
1配置狀態
|
Step 2
|
vtp domain
domain-name
|
配置VTP域
|
Step 3
|
vtp server
|
將Switch 1配置成VTP server.
|
Step 4
|
end
|
退出
|
Step 5
|
show vtp status
|
驗證VTP的配置
|
Step 6
|
show vlan
|
驗證VLAN
|
Step 7
|
configure terminal
|
進入配置狀態
|
Step 8
|
interface fastethernet 0/1 |
進入F0/1端口
|
Step 9
|
switchport mode trunk
|
配置成trunk端口
|
Step 10
|
end
|
退出
|
Step 11
|
show interfaces fastethernet0/1 switchport |
驗證VLAN配置
|
Step 12
|
|
在switch1上的F0/2上重複7到11步驟
|
Step 13
|
|
在Switch 2的F0/1,F0/2上重複7到11步驟。
|
Step 14
|
show vlan
|
當trunk已經起來,在switch2上驗證已經學到相關的vlan配置
|
Step 15
|
configure terminal
|
在Switch 1上進入配置狀態
|
Step 16
|
interface fastethernet0/1
|
進入要配置的端口
|
Step 17
|
spanning-tree vlan 8 port-priority 10
|
將端口權值10賦與VLAN 8.
|
Step 18
|
spanning-tree vlan 9 port-priority 10
|
將端口權值10賦與VLAN 9.
|
Step 19
|
spanning-tree vlan 10 port-priority 10
|
將端口權值10賦與VLAN 10.
|
Step 20
|
exit
|
退回.
|
Step 21
|
interface fastethernet0/2
|
進入F0/2
|
Step 22
|
spanning-tree vlan 3 port-priority 10
|
將端口權值10賦與VLAN 3.
|
Step 23
|
spanning-tree vlan 4 port-priority 10
|
將端口權值10賦與VLAN 4.
|
Step 24
|
spanning-tree vlan 5 port-priority 10
|
將端口權值10賦與VLAN 5.
|
Step 25
|
spanning-tree vlan 6 port-priority 10
|
將端口權值10賦與VLAN 10.
|
Step 26
|
end
|
退出
|
Step 27
|
show running-config
|
驗證配置
|
Step 28
|
copy running-config startup-config
|
保存配置
|
|
|
命令
|
目的
|
Step 1
|
configure terminal
|
進入 Switch
1配置狀態
|
Step 2
|
interface fastethernet 0/1 |
進入F0/1
|
Step 3
|
switchport mode trunk
|
配置Trunk,只能是dot1q模式
|
Step 4
|
exit
|
退回
|
Step 5
|
|
在F0/2口上重複2-4步驟
|
Step 6
|
end
|
退出
|
Step 7
|
show running-config
|
驗證配置
|
Step 8
|
show vlan
|
驗證switch1已經學到Vlan
|
Step 9
|
configure terminal
|
進入配置狀態
|
Step 10
|
interface fastethernet 0/1
|
進入F0/1
|
Step 11
|
spanning-tree vlan 2 cost 30
|
設置Vlan2生成樹路徑值爲30
|
Step 12
|
spanning-tree vlan 3 cost 30
|
設置Vlan3生成樹路徑值爲30
|
Step 13
|
spanning-tree vlan 4 cost 30
|
設置Vlan4生成樹路徑值爲30
|
Step 14
|
end
|
退出
|
Step 15
|
|
在switch1的F0/2上重複9-11步驟設置VLAN8,9,10生成樹路徑值爲30
|
Step 16
|
exit
|
退出
|
Step 17
|
show running-config
|
驗證配置
|
Step 18
|
copy running-config startup-config
|
保存配置
|
ZL-10th -Floor-1中的MAC地址爲:000a.f404.ad80
ZL-10th -Floor-2中的MAC地址爲:000a.f404.a500
ZL-10th -Floor-3中的MAC地址爲:000a.f404.ab80
cluster commander-address 000a.f404.ad80 member 1 name ZL-10th-Floor
cluster commander-address 000a.f404.ad80 member 2 name ZL-10th-Floor
cluster commander-address 000a.f404.ad80 member 3 name ZL-10th-Floor