Game

Game

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 50 Accepted Submission(s): 44
 
Problem Description
Bob and Alice are playing a new game. There are n boxes which have been numbered from 1 to n. Each box is either empty or contains several cards. Bob and Alice move the cards in turn. In each turn the corresponding player should choose a non-empty box A and choose another box B that B<A && (A+B)%2=1 && (A+B)%3=0. Then, take an arbitrary number (but not zero) of cards from box A to box B. The last one who can do a legal move wins. Alice is the first player. Please predict who will win the game.
 
Input
The first line contains an integer T (T<=100) indicating the number of test cases. The first line of each test case contains an integer n (1<=n<=10000). The second line has n integers which will not be bigger than 100. The i-th integer indicates the number of cards in the i-th box.
 
Output
For each test case, print the case number and the winner's name in a single line. Follow the format of the sample output.
 
Sample Input
2
2
1 2
7
1 3 3 2 2 1 2
 
Sample Output
Case 1: Alice
Case 2: Bob
 
Author
hanshuai@whu
 
Source
The 5th Guangting Cup Central China Invitational Programming Contest
 
Recommend
notonlysuccess
 
/*
題意:1到n的盒子裏,是空的或者裝着卡片,每人輪流移動卡片,Alice先手,移動卡片的規則:每次選擇一個A,而後選擇一個B
    要求 B<A&&(A+B)%2==1&&(A+B)%3==0,從A中抽取任意一張卡片放到B中,誰不能移動了,就輸了。

初步思路:這個就是先將能移動的盒子對找出來,而後統計能移動的牌

#錯誤:上面的想法不完善,只是一方面的認爲卡片會從一上一級向下一級移動。

#補充:階梯博弈,實際上卡片是在3的餘數上進行轉移的。

#感悟:手殘用了數組,開小了,wa了兩發才發現
*/
#include<bits/stdc++.h>
using namespace std;
int n;
int x;
int res=0;
int t;
void init(){
    res=0;
}
int main(){
    // freopen("in.txt","r",stdin);
    scanf("%d",&t);
    for(int ca=1;ca<=t;ca++){
        init();
        scanf("%d",&n);
        for(int i=1;i<=n;i++){
            scanf("%d",&x);
            if(i%6==0||i%6==2||i%6==5)
                res^=x;
        }
        if(res) printf("Case %d: Alice\n",ca);
        else printf("Case %d: Bob\n",ca);
    }
    return 0;
}
相關文章
相關標籤/搜索