1005 Spell It Right

1005 Spell It Right
 

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.html

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤).java

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.git

Sample Input:

12345

Sample Output:

one five


這是簽到題目把?
import java.util.*;

public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        String str = sc.next();
        sc.close();
        int res = 0;
        for(int i=0;i<str.length();i++)
            res+=Integer.valueOf(str.charAt(i)-48);
        String result = String.valueOf(res);
        for(int i=0;i<result.length();i++) {
            switch(result.charAt(i)) {
            case '0':
                System.out.print("zero");
                break;
            case '1':
                System.out.print("one");
                break;
            case '2':
                System.out.print("two");
                break;
            case '3':
                System.out.print("three");
                break;
            case '4':
                System.out.print("four");
                break;
            case '5':
                System.out.print("five");
                break;
            case '6':
                System.out.print("six");
                break;
            case '7':
                System.out.print("seven");
                break;
            case '8':
                System.out.print("eight");
                break;
            case '9':
                System.out.print("nine");
                break;
            }
            if(i!=result.length()-1) System.out.print(" ");
        }
    }
}

 

相關文章
相關標籤/搜索