HDU 5437 & ICPC 2015 Changchun Alisha's Party(優先隊列)

Alisha’s Party

Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 7971    Accepted Submission(s): 1833
node

 

Description

Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v, and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.c++

Each time when Alisha opens the door, she can decide to let p people enter her castle. If there are less than p people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.less

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query n Please tell Alisha who the n−th person to enter her castle is.ide

Input

The first line of the input gives the number of test cases, T , where 1≤T≤15.this

In each test case, the first line contains three numbers k,m and q separated by blanks. k is the number of her friends invited where 1≤k≤150,000. The door would open m times before all Alisha’s friends arrive where 0≤m≤k. Alisha will have q queries where 1≤q≤100.spa

The i−th of the following k lines gives a string Bi, which consists of no more than 200 English characters, and an integer vi, 1≤vi≤108, separated by a blank. Bi is the name of the i−th person coming to Alisha’s party and Bi brings a gift of value vi.code

Each of the following m lines contains two integers t(1≤t≤k) and p(0≤p≤k) separated by a blank. The door will open right after the t−th person arrives, and Alisha will let p friends enter her castle.blog

The last line of each test case will contain q numbers n1,...,nq separated by a space, which means Alisha wants to know who are the n1−th,...,nq−th friends to enter her castle.three

Note: there will be at most two test cases containing n>10000.隊列

Output

For each test case, output the corresponding name of Alisha’s query, separated by a space.

Sample Input

1
5 2 3
Sorey 3
Rose 3
Maltran 3
Lailah 5
Mikleo 6
1 1
4 2
1 2 3

Sample Output

Sorey Lailah Rose
 

題目大意

Alisha要舉辦一個party,會有k個來賓,每一個來賓會有一個價值爲vi的禮物,可是Alisha不能同時接待這麼多人,因而她會分好幾回打開大門,放幾我的進來,題目會給出m對數,分別是t和p,即在第t我的到達後,打開大門,在外面排隊的前p我的進來。排隊的方式是根據禮物的價值從高到低排,價值同樣的先來的站前面。最後全部的人都會進來。最後給出q次查詢,詢問第幾個進來的人是誰。

好比題目中,Sorey先來,Alisha在第一我的來到以後,打開門放一我的進來,也就是Sorey。而後Rose、Maltran、Lailah都來了,由於Lailah的禮物貴重,因此他排在前面,Maltran的禮物和Rose同樣,排在Rose後面,如今Alisha開門放前兩我的進來,也就是Lailah和Rose。而後Mikleo拿着價值爲6的禮物站到了Maltran的前面,最後他們都進來了,因而進門的順序是:Sorey Lailah Rose Mikleo Maltran.對於三次查詢 輸出的是前三我的的名字。

分析

這個題目顯然是要採用優先隊列,可是我老是RE,以後看了別人的代碼才恍然大悟:題目給出的m對數,t不必定是按順序來的,也就是說樣例中的 1 1 和 4 2 是能夠反過來的!!因此不能在輸入的時候就完成模擬,這是我一直RE的緣由(原來RE也有多是這樣的.....小弱雞學到了)

代碼實現

#include<bits/stdc++.h>

using namespace std;

typedef struct node
{
    int vul;
    int num;
    char names[205];
    friend bool operator < (const node & a,const node & b)
    {
        return a.vul < b.vul || (a.vul == b.vul && a.num > b.num);
    }    
}vistor;

priority_queue <vistor> pq;

vistor v[150005];
int anss[150005],w[150005];

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        memset(v,0,sizeof(v));
        memset(anss,0,sizeof(anss));
        memset(w,0,sizeof(w));
        while(!pq.empty())
        pq.pop();
        int k,m,q,i,j,s=1,r=0,x,y;
        scanf("%d%d%d",&k,&m,&q);
        for(i=1;i<=k;i++)
        {
            scanf("%s",v[i].names);
            scanf("%d",&v[i].vul);
            v[i].num=i;
        }
        for(i=1;i<=m;i++)
        {
            scanf("%d %d",&x,&y);
            w[x]+=y;  
        }
        for(i=1;i<=k;i++)
        {
            pq.push(v[i]);
            while(w[i]--)
            {
                if(!pq.empty())
                {
                    anss[s++]=pq.top().num;
                    pq.pop();
                }
            }
        }
        while(!pq.empty())
        {
            anss[s++]=pq.top().num;
            pq.pop();
        }
        for(i=1;i<=q;i++)
        {
            scanf("%d",&x);
            if(i!=q)
            printf("%s ",v[anss[x]].names);
            else
            printf("%s\n",v[anss[x]].names);
        }
    }
}
相關文章
相關標籤/搜索