poj 3077Rounders(模擬)

轉載請註明出處:http://blog.csdn.net/u012860063?ios

viewmode=contentsthis

題目連接:http://poj.org/problem?spa

id=3077.net


Descriptionrest

For a given number, if greater than ten, round it to the nearest ten, then (if that result is greater than 100) take the result and round it to the nearest hundred, then (if that result is greater than 1000) take that number and round it to the nearest thousand, and so on ...

Inputcode

Input to this problem will begin with a line containing a single integer n indicating the number of integers to round. The next n lines each contain a single integer x (0 <= x <= 99999999).

Outputblog

For each integer in the input, display the rounded integer on its own line. 

Note: Round up on fives.

Sample Inputip

9
15
14
4
5
99
12345678
44444445
1445
446

Sample Outputci

20
10
4
5
100
10000000
50000000
2000
500


代碼1、例如如下:get

#include <iostream>
#include <cstring>
using namespace std;
int main()
{
	int t, n, k, count;
	char s[17];
	int i, j;
	while(cin >>t)
	{
		while(t--)
		{
			count = 0;
			int p = 0, l = 0;;
			memset(s,0,sizeof(s));
			cin>>s;
			int len = strlen(s);
			if(len == 1)
			{
				cout<<s[0]<<endl;
				continue;
			}
			for(i = len-1; i > 0; i--)
			{
				if(s[i]-'0'+p > 4)
				{
					p = 1;
					count++;
				}
				else
				{
					p = 0;
					count++;
				}
			}
			if(s[0]-'0' + p > 9)
			{
				cout<<10;
			}
			else
			{
				cout<<s[0]-'0'+p;
			}
			for(i = 0; i < count; i++)
			{
				cout<<'0';
			}
			cout<<endl;
		}
	}
	return 0;
}

代碼2、例如如下:

#include <iostream>
#include <cstdlib>
#include <cstring>
#include <cstdio>
using namespace std;

int main()
{
    int t;
    scanf("%d", &t);
    while (t--)
    {
        int n, count = 0;
        scanf("%d", &n);
        double x = n;
        while (x >= 10)
        {
            x /= 10;
            x = (int)(x + 0.5);
            count++;
        }
        n = (int)x;
        for (int i = 0; i < count; i++)
            n *= 10;
        printf("%d\n", n);
    }
    return 0;
}
相關文章
相關標籤/搜索