hdoj 1787 GCD Again【歐拉函數】

GCD Again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2673    Accepted Submission(s): 1123


ide

Problem Description
Do you have spent some time to think and try to solve those unsolved problem after one ACM contest?
No? Oh, you must do this when you want to become a "Big Cattle".
Now you will find that this problem is so familiar:
The greatest common divisor GCD (a, b) of two positive integers a and b, sometimes written (a, b), is the largest divisor common to a and b. For example, (1, 2) =1, (12, 18) =6. (a, b) can be easily found by the Euclidean algorithm. Now I am considering a little more difficult problem: 
Given an integer N, please count the number of the integers M (0<M<N) which satisfies (N,M)>1.
This is a simple version of problem 「GCD」 which you have done in a contest recently,so I name this problem 「GCD Again」.If you cannot solve it still,please take a good think about your method of study.
Good Luck!
 

 

Input
Input contains multiple test cases. Each test case contains an integers N (1<N<100000000). A test case containing 0 terminates the input and this test case is not to be processed.
 

 

Output
For each integers N you should output the number of integers M in one line, and with one line of output for each line in input. 
 

 

Sample Input
2
4
0
 

 

Sample Output
0
1
題意:求2到n-1中與n不互質的數的個數,由於歐拉函數求出的是與n互質的數的個數因此用n-el(n)便可,由於大於一因此還要減去1
#include<stdio.h>
#include<string.h>
int el(int n)
{
	int i;
	int ans=n;
	for(i=2;i*i<=n;i++)//用i*i是爲了提升運算效率 
	{                   
		if(n%i==0)
		    ans=ans/i*(i-1);
		while(n%i==0)
		    n/=i;
	}
	if(n>1)//爲了不沒有運算到1的狀況 
	    ans=ans/n*(n-1);
	return ans;
}
int main()
{
	int n,m,j,i;
	while(scanf("%d",&m),m)
	{
		printf("%d\n",m-el(m)-1);
	}
	return 0;
}
相關文章
相關標籤/搜索