POJ-1659 Frogs' Neighborhood

Descriptionnode

未名湖附近共有N個大小湖泊L1L2, ..., Ln(其中包括未名湖),每一個湖泊Li裏住着一隻青蛙Fi(1 ≤ i ≤ N)。若是湖泊LiLj之間有水路相連,則青蛙FiFj互稱爲鄰居。如今已知每隻青蛙的鄰居數目x1x2, ..., xn,請你給出每兩個湖泊之間的相連關係。數組

Input測試

第一行是測試數據的組數T(0 ≤ T ≤ 20)。每組數據包括兩行,第一行是整數N(2 < N < 10),第二行是N個整數,x1x2,..., xn(0 ≤ xi ≤ N)。spa

Outputcode

對輸入的每組測試數據,若是不存在可能的相連關係,輸出"NO"。不然輸出"YES",並用N×N的矩陣表示湖泊間的相鄰關係,即若是湖泊i與湖泊j之間有水路相連,則第i行的第j個數字爲1,不然爲0。每兩個數字之間輸出一個空格。若是存在多種可能,只需給出一種符合條件的情形。相鄰兩組測試數據之間輸出一個空行。blog

Sample Input排序

3
7
4 3 1 5 4 2 1 
6
4 3 1 4 2 0 
6
2 3 1 1 2 1 

Sample Outputip

YES
0 1 0 1 1 0 1 
1 0 0 1 1 0 0 
0 0 0 1 0 0 0 
1 1 1 0 1 1 0 
1 1 0 1 0 1 0 
0 0 0 1 1 0 0 
1 0 0 0 0 0 0 

NO

YES
0 1 0 0 1 0 
1 0 0 1 1 0 
0 0 0 0 0 1 
0 1 0 0 0 0 
1 1 0 0 0 0 
0 0 1 0 0 0

解題思路:string

這道題目其實就是Havel-Hakimi定理的一個簡單應用。it

Havel-Hakimi定理:由非負數組成的非增序列s:d1,d2,d3,...,dn(n>=2, d1>=1)是可圖的,當且僅當序列s1:d2-1,d3-1,d4-1,...,d(d1+1)-1, d(d1+2),...,dn是可圖的。

好比說:

給定序列爲4 3 1 4 2 0,咱們對其按非增序列排序,獲得4 4 3 2 1 0,刪除首項4,對其後4項每項減1,獲得3 2 1 0 0,

對此再排序,再次刪除首項,獲得序列2 1 -1 0,因爲一個圖裏面的度不可能爲負數,因此這個圖沒法構成圖。

而對於能構成圖的,每次減去1的點對應的下標與被刪去的首項對應的下標構成通路,這道題就解出來了。


代碼:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 10 + 3;

typedef struct node{
    int x, id;
    bool operator < (node a){
        return x > a.x;
    }
}Frog;

int flag;
Frog p[maxn];
int nei[maxn][maxn];

int main()
{
    int t, n;
    scanf("%d", &t);
    while(t--){
        scanf("%d", &n);
        for(int i = 0; i < n; ++i){
            scanf("%d", &p[i].x);
            p[i].id = i;
        }
        
        sort(p, p + n);
        int flag = 1;
        memset(nei, 0, sizeof(nei));
        for(int i = 0; i < n; ++i){
            for(int j = 1; j <= p[0].x; ++j){
                --p[j].x;
                nei[p[0].id][p[j].id] = 1;
                nei[p[j].id][p[0].id] = 1;
                if(p[j].x < 0) flag = 0;
            }
            p[0].x = 0;
            sort(p, p + n);
        }
        if(flag){
            puts("YES");
            for(int i = 0; i < n; ++i){
                for(int j = 0; j < n; ++j){
                    if(j) printf(" ");
                    printf("%d", nei[i][j]);
                }
                puts("");
            }
        }else puts("NO");
        if(t) puts("");
    }
    return 0;
}
相關文章
相關標籤/搜索