機率dp sgu495

 Kids and Prizes
Time Limit:250MS     Memory Limit:262144KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Descriptionphp



ICPC (International Cardboard Producing Company) is in the business of producing cardboard boxes. Recently the company organized a contest for kids for the best design of a cardboard box and selected  M winners. There are  N prizes for the winners, each one carefully packed in a cardboard box (made by the ICPC, of course). The awarding process will be as follows:
  • All the boxes with prizes will be stored in a separate room.
  • The winners will enter the room, one at a time.
  • Each winner selects one of the boxes.
  • The selected box is opened by a representative of the organizing committee.
  • If the box contains a prize, the winner takes it.
  • If the box is empty (because the same box has already been selected by one or more previous winners), the winner will instead get a certificate printed on a sheet of excellent cardboard (made by ICPC, of course).
  • Whether there is a prize or not, the box is re-sealed and returned to the room.
The management of the company would like to know how many prizes will be given by the above process. It is assumed that each winner picks a box at random and that all boxes are equally likely to be picked. Compute the mathematical expectation of the number of prizes given (the certificates are not counted as prizes, of course).

Inputios

The first and only line of the input file contains the values of  N and  M (  ).

Outputless

The first and only line of the output file should contain a single real number: the expected number of prizes given out. The answer is accepted as correct if either the absolute or the relative error is less than or equal to 10  -9.

Sample Inputdom

sample input
sample output
5 7
3.951424

sample input
sample output
4 3
2.3125



題意:有n件獎品裝在n個箱子裏。M我的選擇當中的一個箱子,每個人取出一個箱子。假設有獎品取出,後將箱子放回。後面的人繼續取箱子.問終於取出箱子個數的指望。post

另dp[i]表示第i我的拿到獎品的機率則,dp[1]=1;若i-1取到了獎品則i得到獎品的機率爲dp[i-1]-1/n,不然i獲得獎品的機率爲dp[i-1].轉移方程爲dp[i]=dp[i-1]*(dp[i-1]-1/n)+(1-dp[i-1])*dp[i-1].、ui


/*************************************************************************
    > File Name: t.cpp
    > Author: acvcla
    > Mail: acvcla@gmail.com 
    > Created Time: 2014年10月21日 星期二 21時33分55秒
 ************************************************************************/
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<vector>
#include<cstring>
#include<map>
#include<queue>
#include<stack>
#include<string>
#include<cstdlib>
#include<ctime>
#include<set>
#include<math.h>
using namespace std;
typedef long long LL;
const int maxn = 1e5 + 10;
#define rep(i,a,b) for(int i=(a);i<=(b);i++)
#define pb push_back
int n,m,f;
double dp[maxn];
int main(int argc, char const *argv[])
{
	while(~scanf("%d%d",&n,&m)){
		memset(dp,0,sizeof dp);
		dp[1]=1;
		double ans=1;
		for(int i=2;i<=m;i++){
			dp[i]=dp[i-1]*(dp[i-1]-1.0/n)+(1-dp[i-1])*dp[i-1];
			ans+=dp[i];
		}
		printf("%.10f\n",ans);
	}
	return 0;
}
相關文章
相關標籤/搜索