POJ-3045 Cow Acrobats (C++ 貪心)

Descriptionios

Farmer John's N (1 <= N <= 50,000) cows (numbered 1..N) are planning to run away and join the circus. Their hoofed feet prevent them from tightrope walking and swinging from the trapeze (and their last attempt at firing a cow out of a cannon met with a dismal failure). Thus, they have decided to practice performing acrobatic stunts. 

The cows aren't terribly creative and have only come up with one acrobatic stunt: standing on top of each other to form a vertical stack of some height. The cows are trying to figure out the order in which they should arrange themselves ithin this stack. 

Each of the N cows has an associated weight (1 <= W_i <= 10,000) and strength (1 <= S_i <= 1,000,000,000). The risk of a cow collapsing is equal to the combined weight of all cows on top of her (not including her own weight, of course) minus her strength (so that a stronger cow has a lower risk). Your task is to determine an ordering of the cows that minimizes the greatest risk of collapse for any of the cows.

Inputide

* Line 1: A single line with the integer N. 

* Lines 2..N+1: Line i+1 describes cow i with two space-separated integers, W_i and S_i. 

Outputthis

* Line 1: A single integer, giving the largest risk of all the cows in any optimal ordering that minimizes the risk.

Sample Inputatom

3
10 3
2 5
3 3

Sample Outputspa

2

Hintorm

OUTPUT DETAILS: 

Put the cow with weight 10 on the bottom. She will carry the other two cows, so the risk of her collapsing is 2+3-3=2. The other cows have lower risk of collapsing.
大致題意就是相似疊羅漢,不過一層只有一個,每隻奶牛都有體重和力氣,受到的重量w>力氣s會有風險,求最小風險。
一開始想的是體重輕力氣小的在上,交完發現WA了,最後猜想w和s相加排序,過了。
引用某大神的推導,證實:
DiiWiiSiii,jWi+Si>Wj+Sjij
ij
- Di=Si
- Dj=+WiSj
ji
- Di=+WjSi
- Dj=Sj
顯然咱們能夠獲得
>,>,>
ij
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
struct cow{
	int w,p,sum;
};
int cmp(cow c1,cow c2)
{
	return c1.sum<c2.sum;
}
cow c[50100];
int main()
{
	int n;
	//int w[10100],p[10100];
	//memset(w,0,sizeof(w));
	//memset(p,0,sizeof(p));
	while(~scanf("%d",&n))
	{
		for(int i=0;i<n;i++)
		{
			scanf("%d%d",&c[i].w,&c[i].p);
			c[i].sum=c[i].p+c[i].w;
		}
		//int sum[10100];
		sort(c,c+n,cmp);
		int ans=-0x3f3f3f3f;
		int sum=0;
		for(int i=0;i<n;i++)
		{
			//ans+=c[i].p-c[i-1].w;
			ans=max(ans,sum-c[i].p);
			sum+=c[i].w;
		}
		printf("%d\n",ans);
	}
	return 0;
}
相關文章
相關標籤/搜索