POJ 2407 Relatives (歐拉函數)

題目連接ios

Descriptionc++

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.less

Input函數

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.spa

Outputcode

For each test case there should be single line of output answering the question posed above.ip

Sample Inputget

7
12
0input

Sample Outputit

6
4

分析:
求一個數的全部的小於該數且與該數互質的數的個數,也就是歐拉函數的應用。

直接套歐拉函數公式,即將n素分解後有n=p1^k1p2^k2…pm^km,則euler(n)=n(1-1/p1)(1-1/p2)…*(1-1/pm) 。

代碼:

#include<cstdio>
#include<iostream>
using namespace std;
typedef long long ll;
ll get_euler(ll n)//歐拉函數的應用
{
    ll ans=n;
    for(ll i=2; i*i<=n; i++)
    {
        if(n%i==0)
        {
            ans=ans/i*(i-1);
            while(n%i==0)
                n/=i;
        }
    }
    if(n>1)
        ans=ans/n*(n-1);
    return ans;
}
int main()
{
    ll n;
    while(scanf("%lld",&n),n)
        printf("%lld\n",get_euler(n));
    return 0;
}
相關文章
相關標籤/搜索