hdu 1814 Peaceful Commission

Peaceful Commission

 HDU - 1814 node

The Public Peace Commission should be legislated in Parliament of The Democratic Republic of Byteland according to The Very Important Law. Unfortunately one of the obstacles is the fact that some deputies do not get on with some others. 

The Commission has to fulfill the following conditions: 
1.Each party has exactly one representative in the Commission, 
2.If two deputies do not like each other, they cannot both belong to the Commission.

Each party has exactly two deputies in the Parliament. All of them are numbered from 1 to 2n. Deputies with numbers 2i-1 and 2i belong to the i-th party . 

Task 
Write a program, which: 
1.reads from the text file SPO.IN the number of parties and the pairs of deputies that are not on friendly terms, 
2.decides whether it is possible to establish the Commission, and if so, proposes the list of members, 
3.writes the result in the text file SPO.OUT. 

InputIn the first line of the text file SPO.IN there are two non-negative integers n and m. They denote respectively: the number of parties, 1 <= n <= 8000, and the number of pairs of deputies, who do not like each other, 0 <= m <=2 0000. In each of the following m lines there is written one pair of integers a and b, 1 <= a < b <= 2n, separated by a single space. It means that the deputies a and b do not like each other. 
There are multiple test cases. Process to end of file. 
OutputThe text file SPO.OUT should contain one word NIE (means NO in Polish), if the setting up of the Commission is impossible. In case when setting up of the Commission is possible the file SPO.OUT should contain n integers from the interval from 1 to 2n, written in the ascending order, indicating numbers of deputies who can form the Commission. Each of these numbers should be written in a separate line. If the Commission can be formed in various ways, your program may write mininum number sequence. 
Sample Input
ios

3 2
1 3
2 4

Sample Outputide

1
4
5

 

 

/*
    有n個黨派,每一個黨派有2我的,每一個黨派必須且只能選一我的,存在m種敵對關係,請給出一種兩兩之間不存在敵對關係的策略。
*/
#include<iostream>
#include<cstdio>
#include<cstring>
#define maxn 16010
using namespace std;
int head[maxn],num,ans[maxn],n,m,cnt,col[maxn];
struct node{int to,pre;}e[40010];
void Insert(int from,int to){
    e[++num].to=to;
    e[num].pre=head[from];
    head[from]=num;
}
int other(int x){
    if(x&1)return x+1;
    else return x-1;
}
bool paint(int x){
    if(col[x]!=0)return col[x]%2;
    col[x]=1;col[other(x)]=2;
    ans[++cnt]=x;
    for(int i=head[x];i;i=e[i].pre){
        int to=e[i].to;
        if(!paint(to))return 0;
    }
    return 1;
} 
bool work(){
    memset(col,0,sizeof(col));
    for(int i=1;i<=n*2;i++){
        if(col[i])continue;
        cnt=0;
        if(!paint(i)){
            for(int j=1;j<=cnt;j++)
                col[ans[j]]=col[other(ans[j])]=0;
            if(!paint(other(i)))return 0;
        }
        else continue;
    }
    return 1;
}
int main(){
    while(scanf("%d%d",&n,&m)!=EOF){
        memset(head,0,sizeof(head));num=0;
        int x,y;
        for(int i=1;i<=m;i++){
            scanf("%d%d",&x,&y);
            Insert(x,other(y));
            Insert(y,other(x));
        }
        if(work()){
            for(int i=1;i<=n*2;i++)
                if(col[i]==1)printf("%d\n",i);
        }
        else puts("NIE");
    }
    return 0;
}
相關文章
相關標籤/搜索