Descriptionios
It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds.
Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples).
Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.
Inputapp
* Line 1: Two space separated integers: T and W
* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.
Outputless
* Line 1: The maximum number of apples Bessie can catch without walking more than W times.
Sample Inputui
7 2
2
1
1
2
2
1
1
Sample Outputspa
6
Hintcode
INPUT DETAILS:
Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice.
OUTPUT DETAILS:
Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.
Sourceblog
題意不難理解,兩棵樹,每一分鐘要麼從一號或者二號掉下蘋果,能夠穿梭於兩棵樹之間,固然不能同時接到兩棵樹的蘋果,並且穿梭的次數有限,最初在一號樹下,問能接到多少蘋果,每一分鐘均可以有不一樣的選擇,實際上須要找到一條穿梭的最佳路線,因此咱們須要記錄,某一時間,穿梭幾回的狀態,第i分鐘,穿梭了j次得到蘋果數dp[i][j],只可能承接於兩種狀態,要麼他上一分鐘就已經穿梭了j次了,要麼上一分鐘穿梭了j - 1次,而後判斷第i分鐘穿梭到的位置是否接到蘋果,這很好判斷,若是j是奇數,則在二號樹下,若是j是偶數,就是在一號樹,若是j和樹號的和都是奇數,因此對二取模便可。
代碼:
#include <iostream>
#include <cstdio>
using namespace std;
int dp[1001][31];///第幾分鐘 第幾步 的蘋果數
int apple[1001];
int main() {
int n,m,ans = 0;
scanf("%d%d",&n,&m);
for(int i = 0;i < n;i ++) {
scanf("%d",&apple[i]);
}
dp[1][apple[0] - 1] = 1;///第一分鐘
for(int i = 2;i <= n;i ++) {
dp[i][0] = dp[i - 1][0] + apple[i - 1] % 2;///第i分鐘 0步的蘋果數
for(int j = 1;j <= m;j ++) {
dp[i][j] = max(dp[i - 1][j],dp[i - 1][j - 1]);
dp[i][j] += (apple[i - 1] + j) % 2;///是否接到蘋果
}
}
for(int i = 0;i <= m;i ++) {
ans = max(ans,dp[n][i]);
}
printf("%d",ans);
}
重作ip
代碼:ssl
#include <iostream>
#include <cstdlib>
#include <cstdio>
#include <cstring>
using namespace std;
int t,w,d;
int dp[1001][31];
int main() {
scanf("%d%d",&t,&w);
for(int i = 1;i <= t;i ++) {
scanf("%d",&d);
if(i == 1) dp[i][d - 1] = 1;
else {
dp[i][0] = dp[i - 1][0] + (d == 1);
for(int j = 1;j <= w;j ++) {
dp[i][j] = max(dp[i - 1][j],dp[i - 1][j - 1]);
dp[i][j] += (d - 1 == j % 2);
}
}
}
int ans = 0;
for(int i = 1;i <= w;i ++) {
ans = max(ans,dp[t][i]);
}
printf("%d",ans);
}