Steps POJ - 2590

Steps
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8219 Accepted: 3747
Description


One steps through integer points of the straight line. The length of a step must be nonnegative and can be by one bigger than, equal to, or by one smaller than the length of the previous step. 
What is the minimum number of steps in order to get from x to y? The length of the first and the last step must be 1.
Input


Input consists of a line containing n, the number of test cases.
Output


For each test case, a line follows with two integers: 0 <= x <= y < 2^31. For each test case, print a line giving the minimum number of steps to get from x to y.
Sample Input


3
45 48
45 49
45 50
Sample Output


3
3

4ios

貪心作法,先把 x寫成1+2+3+.....+n+n-1+n-2+n-3+....+2+1的形式,再把剩下的放進去。spa

上面的式子等於 n^2,因此先判斷x是否爲平方數,若是是的話直接輸出 2*k-1,若是不是在加上剩下。ip

#include<map>
#include<stack>
#include<queue>
#include<math.h>
#include<vector>
#include<string>
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
#define maxn 1100000
#define maxm 1000000000005
#define mod 1000000007
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
     ll x,y;scanf("%lld%lld",&x,&y);
     if(x==y){
        printf("0\n");continue;
     }
     ll k=sqrt((y-x)*1.0);
     if(k*k==y-x)printf("%lld\n",2*k-1);
     else {
        ll ans=(y-x)-k*k;
        ll ans1=2*k-1;
        while(ans!=0){
           ans1+=(ans/k);
           ans%=k;
           k--;
        }
        printf("%lld\n",ans1);
     }
    }
}
相關文章
相關標籤/搜索