#1061. 統計單詞數

別點最後一個連接

 

題目來源:

http://www.51cpc.com/problem/1061html

 

題目描述

輸入一段英文句子,請統計句子中的單詞數目ide

輸入格式

輸入一段英文句子(長度小於1000)包含空格ui

輸出格式

輸出單詞數目spa

樣例

Sample Input:code

It matters not what someone is born, but what they grow to be.

Sample Output:htm

13



#include<stdio.h>
char str[1000];
int main()
{
    char ch;
    int i,word=0,count=0;
    gets(str);
    for(i=0;(ch=str[i])!='\0';i++)
    {
        if(ch==' ') word=0;
        else if(word==0)
        {
            word=1;
            count++;
        }
    }
    printf("%d\n",count);
    return 0;
}
記得點贊哦!

思路:分析樣例,會發現每一個單詞前有個空格。blog

假如沒有發現這個特色也能夠將標點符號改爲空格。get

 

更多思路:io

http://www.javashuo.com/article/p-pfwgeopu-em.htmlclass

 

記得點贊哦!

相關文章
相關標籤/搜索