Triangle LOVE
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2271 Accepted Submission(s): 946
ios
Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a 「Triangle Love」 among N people. 「Triangle Love」 means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a 「Triangle Love」.
Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A
i,j = 1 means i-th people loves j-th people, otherwise A
i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A
i,i= 0, A
i,j ≠ A
j,i(1<=i, j<=n,i≠j).
Output
For each case, output the case number as shown and then print 「Yes」, if there is a 「Triangle Love」 among these N people, otherwise print 「No」.
Take the sample output for more details.
Sample Input
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
Sample Output
題意:給你一個特殊的有向圖,該有向圖的隨意兩個節點u與v之間有且僅有一條單向邊,現在問你該有向圖是否存在由3個節點構成的環.
該圖本質是拓撲排序題.假設該圖可以拓撲排序,那麼不存在3節點的環,不然存在3節點的環.ide
#include<cstdio>
#include<iostream>
#include<cstring>
#include<queue>
#include<algorithm>
#include<vector>
using namespace std;
const int M = 2000 + 5;
int n;
int in[M];
char str[M];
int t;
vector<int> map[M];
bool toposort()
{
int sum = 0;
queue<int>Q;
for(int i=0; i<n; i++)
if( !in[i] )
Q.push( i );
while( !Q.empty() )
{
int u = Q.front();
Q.pop();
sum++;
for(int i=0; i<map[u].size(); i++)
{
int m = map[u][i];
if( --in[m] == 0 )
Q.push( m );
}
}
if( sum==n )
return true;
else
return false;
}
int main()
{
scanf( "%d", &t );
int cas;
for( cas=1; cas<=t; cas++ )
{
scanf( "%d", &n );
memset( in, 0, sizeof( in ) );
for( int i=0; i<n; i++ )
{
map[i].clear();
scanf( "%s", str );
for( int j=0; j<n; j++ )
//for(int j=0; j<strlen(str); j++)
//這麼寫會超時,複雜度會添加
{
if( str[j]=='1' )
{
map[i].push_back( j );
in[ j ]++;
}
}
}
printf("Case #%d: %s\n", cas, toposort()?"No":"Yes");
}
return 0;
}