配置步驟及思路:
一 . 建立vlan並將端口加入設置trunk
1.在lsw4上建立vlan10,vlan20並將端口加入html
# vlan: vlan 10 interface ge0/0/2 port link-type access port default vlan 10 vlan20 interface ge0/0/3 port link-type access port default vlan 20 # trunk: interface ge0/0/1 port link-type trunk port trunk allow-pass vlan all //容許全部vlan interface ge0/0/4 port link-type trunk port trunk allow-pass vlan all //容許全部vlan 2.在lsw5上建立vlan10並將端口加入 . # vlan 10 interface ge0/0/2 port link-type access port default vlan 10 #trunk: interface ge0/0/1 port link-type trunk port trunk allow-pass vlan all //容許全部vlan 3. 在lsw6上建立vlan10並將端口加入 . # vlan 40 interface ge0/0/2 port link-type access port default vlan 40 interface ge0/0/3 port link-type access port default vlan 40 interface ge0/0/4 port link-type access port default vlan 40 interface ge0/0/1 port link-type access port default vlan 40 #trunk: interface ge0/0/1 port link-type trunk port trunk allow-pass vlan all //容許全部vlan
二. 在三層交換機上設置網關進行trunk
1.在lsw2上進行trunk
#trunk:
interface ge0/0/2
port link-type trunk
port trunk allow-pass vlan all //容許全部vlan
interface ge0/0/3
port link-type trunk
port trunk allow-pass vlan all //容許全部vlan
interface ge0/0/4
port link-type trunk
port trunk allow-pass vlan all //容許全部vlan
配置網關:
vlan10
interface vlan 10
ip address 192.168.1.254 255.255.255.0
quit 退出
vlan20
interface vlan 20
ip address 192.168.2.254 255.255.255.0
quit 退出
建立vlan30並加入端口
vlan30
interface ge0/0/1
port link-type access
port default vlan 30
建立vlan50配置IP
vlan50
ip address 192.168.50.1 255.255.255.0web
2.在lsw3上進行trunk #trunk: interface ge0/0/2 port link-type trunk port trunk allow-pass vlan all //容許全部vlan interface ge0/0/1 port link-type trunk port trunk allow-pass vlan all //容許全部vlan 配置網關: vlan30 interface vlan 30 ip address 192.168.1.254 255.255.255.0 quit 退出 vlan40 interface vlan 40 ip address 192.168.2.254 255.255.255.0 quit 退出 建立vlan50配置IP vlan50 ip address 192.168.50.2 255.255.255.0
3、配置RIP服務器
在lsw2上配置RIP
rip
version 2 版本
network 192.168.1.0 要學習的網段
network 192.168.2.0 要學習的網段
network 192.168.30.0 要學習的網段
network 192.168.4.0 要學習的網段app
在lsw3上配置RIP
rip
version 2 版本
network 192.168.50.0 要學習的網段
network 192.168.4.0 要學習的網段
四..測試讓全網互通
在客戶機ping x.x.x.x (任意一個客戶機)
若是ping不一樣一層一層查看
display vlan 查看是否建立vlan和加入的端口
display ip interface brief 查看是否配置網關
display port vlan 查看是否設置了trunk
display rip 查看是否設置了RIP
五.配置服務器
1.在server1中配置
ip:192.168.30.88
子網掩碼:255.255.255.0
網關:192.168.30.254
在服務器信息中DNSServer配置
域名:www.ntd1711.com
ip地址:192.168.30.1
啓動服務器
2.在server2中配置
ip:192.168.30.1
子網掩碼:255.255.255.0
網關:192.168.30.254
在服務器信息中HttpServer配置
域名:www.ntd1711.com
建立根目錄:在任意磁盤中建立一個html格式的文件tcp
2.在Client1中配置
ip:192.168.4.3
子網掩碼:255.255.255.0
網關:192.168.4.25
在服務器信息中HttpClient配置
輸入 地址:www.ntd1711.com
看是否能獲取到文件,能則成功不然失敗。
六.建立acl 具體要求以下:
一、PC-1與PC-2之間的任何類型的流量都沒法互通;
二、PC-3能夠 ping 192.168.30.88(server-2),可是沒法 ping www.ntd1711.com ;
三、PC-4與PC-3之間的任何類型的流量都沒法互通;
四、Client-1 能夠 ping www.ntd1711.com,可是沒法經過自帶的瀏覽 器打開
Server-2中的 web 功能(即,www.ntd1711.com)
七..讓PC-1與PC-2之間的任何類型的流量都沒法互通;
一、建立ACL
[R2]acl 3000
[R2-acl-advance-3000]rule 5 deny ip source 192.168.1.1 0.0.0.0
destination 192.168.1.2 0.0.0.0
注:192.168.1.1 源目標地址
192.168.1.2 目標地址
二、調用ACL
[R2]interface gi0/0/2
[R2-gi0/0/0]traffic-filter inbound acl 3000
三、驗證、測試、保存
display acl 3000 //查看ACL的配置條目信息;
display traffic-filter applied-record //查看ACL的調用信息;
PC1:
ping 192.168.1.2 ,no
ping 別的ok
八 .PC-3能夠 ping 192.168.30.88(server-2),可是沒法 ping www.ntd1711.com
一、在lsw2建立ACL
[R2]acl 3000
[R2-acl-advance-3000]rule 5 deny ip source 192.168.2.1 0.0.0.0 destination 192.168.30.88 0.0.0.0
注:192.168.2.1 源目標地址
192.168.30.88 目標地址
二、調用ACL
[R2]interface gi0/0/3
[R2-gi0/0/0]traffic-filter inbound acl 3000
三、驗證、測試、保存
display acl 3000 //查看ACL的配置條目信息;
display traffic-filter applied-record //查看ACL的調用信息;
PC1:
ping 192.168.30.88 ,no
ping 別的ok
九.PC-4與PC-3之間的任何類型的流量都沒法互通;
一、在lsw3建立ACL
[R2]acl 3000
[R2-acl-advance-3000]rule 5 deny ip source 192.168.4.1 0.0.0.0 destination 192.168.1.2 0.0.0.0
注:192.168.4.1 源目標地址
192.168.1.2 目標地址
二、調用ACL
[R2]interface gi0/0/2
[R2-gi0/0/0]traffic-filter inbound acl 3000
三、驗證、測試、保存
display acl 3000 //查看ACL的配置條目信息;
display traffic-filter applied-record //查看ACL的調用信息;
PC1:
ping 192.168.1.2 ,no
ping 別的ok
十. Client-1 能夠 ping www.ntd1711.com,可是沒法經過自帶的瀏覽 器打開 Server-2中的 web 功能(即,www.ntd1711.com)
一、在lsw3建立ACL
[R2]acl name client1 advance
[R2-acl-advance-3000]rule 10 deny tcp source 192.168.4.3 0.0.0.0 destination 192.168.30.1 0.0.0.0
注:192.168.4.1 源目標地址
192.168.1.2 目標地址
tcp: http的 一種協議
二、調用ACL
[R2]interface gi0/0/2
[R2-gi0/0/0]traffic-filter inbound acl client1
三、驗證、測試、保存
display acl name client1 //查看ACL的配置條目信息;
display traffic-filter applied-record //查看ACL的調用信息;
client1:
在http中輸入:http;//www.ntd1711.com 結果顯示不通就ok
注意事項:
一、同一個端口的,同一個方向,只能同時存在一個 ACL ;ide
二、若是想更改端口上調用的 ACL ,必須:
首先,刪除端口上的 ACL 調用命令;
再次,從新調用一個新的 ACL ; 學習
三、端口上的 ACL ,不容許直接覆蓋;測試
四、華爲中的ACL,沒有匹配住的流量,默認是容許的;ui