HDU 1429 勝利大逃亡(續) (bfs+狀態壓縮)

勝利大逃亡(續)

題目連接:

http://acm.hust.edu.cn/vjudge/contest/71151#problem/Dnode

Description


Ignatius再次被魔王抓走了(搞不懂他咋這麼討魔王喜歡)……
此次魔王汲取了上次的教訓,把Ignatius關在一個n*m的地牢裏,並在地牢的某些地方安裝了帶鎖的門,鑰匙藏在地牢另外的某些地方。剛開始Ignatius被關在(sx,sy)的位置,離開地牢的門在(ex,ey)的位置。Ignatius每分鐘只能從一個座標走到相鄰四個座標中的其中一個。魔王每t分鐘回地牢視察一次,若發現Ignatius不在原位置便把他拎回去。通過若干次的嘗試,Ignatius已畫出整個地牢的地圖。如今請你幫他計算可否再次成功逃亡。只要在魔王下次視察以前走到出口就算離開地牢,若是魔王回來的時候恰好走到出口或還未到出口都算逃亡失敗。
ios

Input


每組測試數據的第一行有三個整數n,m,t(2<=n,m<=20,t > 0)。接下來的n行m列爲地牢的地圖,其中包括:
測試

. 表明路 
* 表明牆 
@ 表明Ignatius的起始位置 
^ 表明地牢的出口 
A-J 表明帶鎖的門,對應的鑰匙分別爲a-j 
a-j 表明鑰匙,對應的門分別爲A-J

每組測試數據之間有一個空行。
spa

Output


針對每組測試數據,若是能夠成功逃亡,請輸出須要多少分鐘才能離開,若是不能則輸出-1。
code

Sample Input

4 5 17
@A.B.
a*.*.
*..*^
c..b*

4 5 16
@A.B.
a*.*.
*..*^
c..b*

Sample Output

16
-1


題意:


在n*m的地圖上,有10種類型的門及其對應鑰匙,求最少的時間從起點到達終點,T-1內不能到達則輸出-1.
ip


題解:


相似魔塔的搜索題,這裏用bfs來搜最小步數便可. 用狀態壓縮處理每一個位置拿到的鑰匙狀態.
判重:除了點座標外,須要額外記錄達到當前點的鑰匙狀態. (由於有些位置可能重複到達).
input


代碼:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
#include <set>
#include <stack>
#include <vector>
#include <list>
#define LL long long
#define eps 1e-8
#define maxn 25
#define mod 100000007
#define inf 0x3f3f3f3f
#define mid(a,b) ((a+b)>>1)
#define IN freopen("in.txt","r",stdin);
using namespace std;

int n, m, T;
char mp[maxn][maxn];
bool vis[maxn][maxn][1<<10];

bool is_ok(int x, int y) {
    return x>=0 && y>=0 && x<n && y<m;
}

struct node {
    int x,y;
    int step, key;
};
int dir[4][2] = {{0,1},{0,-1},{1,0},{-1,0}};

int bfs(int sx, int sy) {
    queue<node> q;
    while(!q.empty()) q.pop();
    node cur, next;
    cur.x = sx, cur.y = sy, cur.step = 0, cur.key = 0;
    q.push(cur);
    vis[sx][sy][0] = 1;

    while(!q.empty()) {
        cur = q.front(); q.pop();

        for(int i=0; i<4; i++) {
            int xx = cur.x + dir[i][0];
            int yy = cur.y + dir[i][1];
            if(!is_ok(xx,yy) || mp[xx][yy]=='*') continue;
            next.x = xx, next.y = yy, next.step = cur.step + 1; next.key = cur.key;

            if(next.step == T) continue;
            if(mp[xx][yy] == '^') return next.step;

            if(mp[xx][yy]>='a' && mp[xx][yy]<='z') {
                next.key |= (1 << (mp[xx][yy]-'a'));
            }

            if(mp[xx][yy]>='A' && mp[xx][yy]<='Z') {
                if((next.key & (1 << (mp[xx][yy]-'A'))) == 0)
                    continue;
            }

            if(vis[next.x][next.y][next.key]) continue;
            vis[next.x][next.y][next.key] = 1;
            q.push(next);
        }
    }

    return -1;
}

int main(int argc, char const *argv[])
{
    //IN;

    while(scanf("%d %d %d", &n,&m,&T) != EOF)
    {
        for(int i=0; i<n; i++)
            scanf("%s", mp[i]);

        int sx = -1, sy = -1;
        for(int i=0; i<n; i++) {
            for(int j=0; j<m; j++) if(mp[i][j] == '@') {
                sx = i, sy = j; break;
            }
            if(sx != -1) break;
        }

        memset(vis, 0, sizeof(vis));
        int ans = bfs(sx, sy);

        printf("%d\n", ans);
    }

    return 0;
}
相關文章
相關標籤/搜索