雙倍數 題解

Description:

一個P進制的N位數A,將A的最後一位放到最高位獲得新的N位數B,若是知足B = 2 * A(P進制下),那麼稱A爲P進制下的雙倍數。現給出進制P,求該進制下的最小雙倍數M。c++

Input:

共k行,每行一個整數Pi,表示進製爲Pi。spa

Output:

共k行,每行一個對應Pi進制下最小的雙倍數Mi,Mi的每一位用一個空格隔開。debug

Example Input:

2
35code

Example Output

0 1
11 23ip

Data Range:

數據組數n ≤ 200
進制數P ≤ 200input

Extra Explanation:

0能夠作最高位(如樣例中2的最小雙倍數),但不能只有0。
對於進制N,每一位用0 ~ N - 1表示。it


Difficulty: ★★☆☆☆

Thoughts:

思路1:

對於每個Mi,枚舉位數,獲得的第一個知足條件的數即便最小的P進制下的雙倍數。io

思路2:

對於對於進制Pi下的Mi,枚舉最後1位,枚舉P次便可。獲得結果後須要與目前答案進行大小比較。test

特判:

有一類特殊狀況咱們能夠直接輸出,就是進制數Pi % 3 == 2時,最小雙倍數必定是(Pi / 3) (Pi / 3 * 2 + 1)。搜索


AC代碼:

思路1:

//Skq_Liao

#include <bits/stdc++.h>
using namespace std;

#define FOR(i, a, b) for (register int i = (a), i##_end_ = (b); i < i##_end_; ++i)
#define ROF(i, a, b) for (register int i = (a), i##_end_ = (b); i > i##_end_; --i)
#define debug(...) fprintf(stderr, __VA_ARGS__)
const int MAXN = 20005;

int A[MAXN];

void Cal(int n)
{
    if(n % 3 == 2)//特判
    {
        printf("%d %d\n", n / 3, n / 3 * 2 + 1);
        return ;
    }
    for(int i = 2; ; ++i) // 枚舉位數
        FOR(j, 1, n) // 枚舉最後一位
        {
            A[i] = j;
            A[i - 1] = 0;
            ROF(k, i - 1, 0) //模擬該進制下的加法
            {
                A[k] += A[k + 1] * 2;
                A[k - 1] = A[k] / n;
                A[k] %= n;
            } 
            if(A[i] == A[1] * 2 + A[0])//若是知足條件,輸出並結束搜索
            {
                FOR(k, 1, i + 1)
                    printf("%d ", A[k]);
                putchar('\n');
                return ;
            }
        }
}

int main()
{
#ifdef Bxy
    freopen("test.in", "r", stdin);
#endif
    int cur;
    while(~scanf("%d", &cur))
        Cal(cur);
    return 0;
}

思路2:

//MisakaMikoto

#include <bits/stdc++.h>
using namespace std;

#define FOR(i, a, b) for (register int i = (a), i##_end_ = (b); i < i##_end_; ++i)
#define ROF(i, a, b) for (register int i = (a), i##_end_ = (b); i > i##_end_; --i)
#define debug(...) fprintf(stderr, __VA_ARGS__)
const int MAXN = 20005;

int p;
int Ans[MAXN];

inline bool Check(int x, int y)
{
    if((Ans[1] * 2 + y) != Ans[x])
        return 0;
    return 1;
}

inline int Solve(int x)
{
    if(x % 3 == 2)
    {
        Ans[1] = x / 3;
        Ans[2] = x / 3 * 2 + 1;
        return 3;
    }
    for(int pos = 2;; ++pos)
        FOR(j, 1, x)
        {
            int carry = 0;
            Ans[pos] = j;
            ROF(i, pos - 1, 0)
            {
                Ans[i] = (carry + (Ans[i + 1] * 2)) % x;
                carry = ((Ans[i + 1] * 2) + carry) / x;
            }
            if(Check(pos, carry))
                return pos + 1;
        }
}

int main()
{
#define Bxy
#ifdef Bxy
    freopen("test.in", "r", stdin);
#endif
    while(~scanf("%d", &p))
    {
        FOR(i, 1, Solve(p))
            printf("%d ", Ans[i]);
        putchar('\n');
    }
    return 0;
}

總結:

此題難度不大,核心在於如何想到雙倍數的構造方法。

Skq_Liao 2017/06/25 10 : 15 於機房

相關文章
相關標籤/搜索