一.拓撲圖redis
二.網段分配網絡
R1oop |
S1/0spa |
192.168.43.1/24router |
R6接口 |
F1/0ip |
10.43.30.1/24ci |
|
R2路由 |
S1/0terminal |
192.168.43.2/24 |
R7 |
F1/0 |
10.43.20.2/24 |
|
R3 |
幀中繼無地址 |
|
F0/0 |
10.43.30.2/24 |
||
R4 |
S1/0 |
192.168.43.4/24 |
|
F0/1 |
10.43.40.2/24 |
|
|
F0/0 |
10.43.10.1/24 |
R8 |
F0/1 |
10.43.40.1/24 |
|
R5 |
F0/0 |
1.43.10.2/24 |
|
|
|
|
|
F0/1 |
10.43.20.1/24 |
|
|
|
|
R6 |
F0/0 |
10.43.10.3/24 |
|
|
|
|
本地還回地址 |
||||||
R1 |
1.1.1.1/24 |
R6 |
5.5.5.5/24 |
|||
R2 |
2.2.2.2/24 |
R7 |
6.6.6.6/24 |
|||
R4 |
3.3.3.3/24 |
R8 |
7.7.7.7/24 |
|||
R5 |
4.4.4.4/24 |
|
|
三.配置過程
(1)幀中繼部分
R4:
interface Loopback0
ip address 3.3.3.3 255.255.255.0
ip ospf network point-to-point 使路由正常。
interface Serial1/0
ip address 192.168.43.4 255.255.255.0
encapsulation frame-relay 封裝成幀中繼。
ip ospf network non-broadcast 配置成NBMA的網絡。
ip ospf priority 255 使R1成爲DR。接口清閒級。
frame-relay map ip 192.168.43.1 103 broadcast 用廣播方式發送幀中繼信息。靜態映射。(注意:對方IP和己方DLCI)
frame-relay map ip 192.168.43.2 104 broadcast
no frame-relay inverse-arp 關閉自動映射。
router ospf 1
log-adjacency-changes
Network 10.43.10.0 0.0.0.255 area0
network 3.3.3.0 0.0.0.255 area 2
network 192.168.0 0.0.0.255 area 2
neighbor 192.168.43.1 priority 3 在NBMA的網絡中,只能使用neighbor來指明鄰居還能夠指明鄰居的優先級。
neighbor 192.168.43.2
R3:
frame-relay switching 配置成幀中繼交換機。此命令很重要。
interface Serial1/1
no ip address
encapsulation frame-relay 封裝成幀中繼
clockrate 128000
frame-relay lmi-type cisco 配置幀中繼的類型
frame-relay intf-type dce 配置幀中繼爲DCE
frame-relay route 103 interface Serial1/0 301 作幀中繼映射
frame-relay route 104 interface Serial1/2 401
interface Serial1/0
no ip address
encapsulation frame-relay
clockrate 128000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 301 interface Serial1/1 103
interface Serial1/2
no ip address
encapsulation frame-relay
clockrate 128000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 401 interface Serial1/1 104
R1:
interface Loopback0
ip address 1.1.1.1 255.255.255.0
ip ospf network point-to-point
interface Serial0/1
ip address 192.168.43.1 255.255.255.0
encapsulation frame-relay
ip ospf network non-broadcast
ip ospf priority 3
frame-relay map ip 192.168.43.4 301 broadcast
frame-relay map ip 192.168.43.2 301 broadcast
no frame-relay inverse-arp
router ospf 1
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 2
network 192.168.0 0.0.0.255 area 2
R2配置同R1
(2)ospf路由部分
R5
conf terminal
router ospf 1
router-id 4.4.4.4
area 1 nssa
network 4.4.4.0 0.0.0.255 area 0
network 10.43.10.0 0.0.0.255 area 0
network 10.43.20.0 0.0.0.255 area 1
R6與R5配置相同,R4前面配過ospf省略
(2)ripng部分
R7
configure terminal
router ospf 1
router-id 6.6.6.6
area 1 nssa
network 10.43.20.0 0.0.0.255 area 1
network 10.43.30.0 0.0.0.255 area 1
redistribute rip metric 25 subnets //RIP->ospf
router rip
version 2
network 10.0.0.0
no auto-summary
redistribute ospf 1 metric 4 //ospf->Rip
R8
configure terminal
router rip
Network 10.43.40.0
Network 7.7.7.0
此時已經能夠從R8ping到幀中繼的R2了。
二.Ospfv3
1. 首先配置幀中繼
2. 配置ospfv3
3. 拓撲規劃
4. 地址規劃
R1 |
S1/0 |
2001:db8:43:abc::1/64 |
R2 |
S1/0 |
2001:db8:43:abc::2/64 |
R4 |
S1/0 |
2001:db8:43:abc::3/64 |
|
F0/0 |
2001:db8:43:10::1/64 |
R5 |
F0/0 |
2001:db8:43:10::2/64 |
|
F0/1 |
2001:db8:43:20::1/64 |
R6 |
F0/0 |
2001:db8:43:10::3/64 |
|
F1/0 |
2001:db8:43:30::1/64 |
R7 |
F0/0 |
2001:db8:43:30::2/64 |
|
F1/0 |
2001:db8:43:20::2/64 |
r4
configure terminal
ipv6 unicast-routing
interface Serial 1/0
frame-relay map ipv6 2001:DB8:43:abc::1 402 broadcast
frame-relay map ipv6 2001:DB8:43:abc::2 401 broadcast
frame-relay map ipv6 FE80::CE01:1EFF:FE28:0 401 broadcast
frame-relay map ipv6 FE80::CE02:EFF:FE60:0 402 broadcast
R1
configure terminal
ipv6 unicast-routing
interface Serial1/0
frame-relay map ipv6 2001:DB8:43:abc::3 202 broadcast
frame-relay map ipv6 2001:DB8:43:abc::2 201 broadcast
frame-relay map ipv6 FE80::CE01:1EFF:FE28:0 201 broadcast
frame-relay map ipv6 FE80::CE04:19FF:FE18:0 202 broadcast
R2
configure terminal
ipv6 unicast-routing
interface Serial1/2
frame-relay map ipv6 2001:DB8:43:abc::3 102 broadcast
frame-relay map ipv6 2001:DB8:43:abc::1 101 broadcast
frame-relay map ipv6 FE80::CE04:19FF:FE18:0 102 broadcast
frame-relay map ipv6 FE80::CE02:EFF:FE60:0 101 broadcast
配置ospf
r4
configure terminal
ipv6 router ospf 1
router-id 3.3.3.3
area 0 range 2001:db8:43::/64
interface Serial1/0
ipv6 ospf 1 area 2
ipv6 enable
ipv6 ospf neighbor FE80::CE02:EFF:FE60:0 priority 1
ipv6 ospf neighbor FE80::CE01:1EFF:FE28:0 priority 1
interface fastEthernet 0/0
ipv6 ospf 1 area 0
R2同R1
R1
configure terminal
ipv6 router ospf 1
router-id 5.5.5.5
interface Serial1/0
ipv6 ospf 1 area 2
ipv6 enable
配置OSPFV3
R6參考R5配置
R5
configure terminal
ipv6 unicast-routing
ipv6 router ospf 1
router-id 4.4.4.4
area 1 nssa
interface fastEthernet 0/0
ipv6 enable
ipv6 ospf 1 area 0
interface fastEthernet 0/1
ipv6 enable
ipv6 ospf 1 area 1
R7
configure terminal
ipv6 unicast-routing
ipv6 router rip ys
redistribute ospf 1 metric 4
redistribute connected
ipv6 router ospf 1
router-id 6.6.6.6
area 1 nssa
redistribute rip ys
redistribute connected
四.實驗總結
此次實驗作的十分艱難,有許多上課作過得實驗在實際作做業的時候會作不通,其實是自己沒有很好的總結上課的內容,表面上作通作會了,實際上沒有深入瞭解其中的原理和其餘的應用方法,致使拓撲稍微複雜或者變更就不會了。
此次做業體驗最深的是幀中繼那部分,並無經過配置ip地址來實現報文的交換在此次實驗中有很深的體會。同時此次做業在查錯的時候之外的更加了解了route-id的決定原理以及手動添加變動刪除route-id的指令。
同時仍是不太瞭解路由彙總與重發布的具體做用以及意義,只是知道大體的配置與做用,會在此次做業以後好好研究。