HDU1560 DNA sequence(IDA*)題解

DNA sequence

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3503    Accepted Submission(s): 1681


Problem Description
The twenty-first century is a biology-technology developing century. We know that a gene is made of DNA. The nucleotide bases from which DNA is built are A(adenine), C(cytosine), G(guanine), and T(thymine). Finding the longest common subsequence between DNA/Protein sequences is one of the basic problems in modern computational molecular biology. But this problem is a little different. Given several DNA sequences, you are asked to make a shortest sequence from them so that each of the given sequence is the subsequence of it.

For example, given "ACGT","ATGC","CGTT" and "CAGT", you can make a sequence in the following way. It is the shortest but may be not the only one.

 

Input
The first line is the test case number t. Then t test cases follow. In each case, the first line is an integer n ( 1<=n<=8 ) represents number of the DNA sequences. The following k lines contain the k sequences, one per line. Assuming that the length of any sequence is between 1 and 5.
 

Output
For each test case, print a line containing the length of the shortest sequence that can be made from these sequences.
 

Sample Input
 
 
14ACGTATGCCGTTCAGT
 
Sample Output
 
 
8

思路:html

剛開始BFS就爆內存了。ios

新思路是給dfs加一個最小限制,超過限制就返回,而後不斷加大限制直到符合,那麼此時dfs的答案也是最小的。這裏有幾個要剪枝的地方:一是超過限制剪枝;二是預估值+當前值超過限制也要剪枝。ide

一開始看的那些題解都看不懂的我emmmm......orzui

借鑑題解:連接this


Code:spa

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cctype>
#include<queue>
#include<cmath>
//#include<map>
#include<iostream>
#include<algorithm>
#define INF 0x3f3f3f3f
const int N=810;
using namespace std;
char str[10][10],dna[4]={'A','C','G','T'};
int n,deep,ans,len[10];
void dfs(int step,int pos[]){	//step爲當前長度 
	if(step>deep) return;	//超過深度返回 
	int maxdeep=0;
	for(int i=0;i<n;i++){
		maxdeep=max(len[i]-pos[i],maxdeep);	//maxdeep爲預估剩餘深度  
	} 
	if(step+maxdeep>deep) return;	//當前長度加預估剩餘深度大於deep,剪枝 
	if(maxdeep==0){	//全部串都知足
		ans=deep;
		return;
	}
	int temp[10],flag;
	for(int i=0;i<4;i++){
		flag=0;
		for(int j=0;j<n;j++){
			if(str[j][pos[j]]==dna[i]){
				temp[j]=pos[j]+1;
				flag=1;
			}
			else temp[j]=pos[j];
		}
		if(flag){
				dfs(step+1,temp);
		}
		if(ans) return;
	}
} 
 int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		deep=0;
		scanf("%d",&n);
		for(int i=0;i<n;i++){
			scanf("%s",str[i]);
			len[i]=strlen(str[i]);
			deep=max(deep,len[i]);	//找出最長的做爲第一次深搜最小深度 
		}
		ans=0;
		int pos[10];	//表示第i組驗證到第pos[i]個 
		memset(pos,0,sizeof(pos));
		while(1){
			dfs(0,pos);
			if(ans) break;
			deep++;	//加深迭代深度,從新DFS 
		}
		printf("%d\n",ans);
	}
	return 0;
}
相關文章
相關標籤/搜索