Hiking 分類: 比賽 HDU 函數 2015-08-09 21:24 3人閱讀 評論(0) 收藏

Hiking
Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 932 Accepted Submission(s): 483
Special Judgenode

Problem Description
There are n soda conveniently labeled by 1,2,…,n. beta, their best friends, wants to invite some soda to go hiking. The i-th soda will go hiking if the total number of soda that go hiking except him is no less than li and no larger than ri. beta will follow the rules below to invite soda one by one:
1. he selects a soda not invited before;
2. he tells soda the number of soda who agree to go hiking by now;
3. soda will agree or disagree according to the number he hears.ios

Note: beta will always tell the truth and soda will agree if and only if the number he hears is no less than li and no larger than ri, otherwise he will disagree. Once soda agrees to go hiking he will not regret even if the final total number fails to meet some soda’s will.markdown

Help beta design an invitation order that the number of soda who agree to go hiking is maximum.less

Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:ui

The first contains an integer n (1≤n≤105), the number of soda. The second line constains n integers l1,l2,…,ln. The third line constains n integers r1,r2,…,rn. (0≤li≤ri≤n)
It is guaranteed that the total number of soda in the input doesn’t exceed 1000000. The number of test cases in the input doesn’t exceed 600.spa

Output
For each test case, output the maximum number of soda. Then in the second line output a permutation of 1,2,…,n denoting the invitation order. If there are multiple solutions, print any of them.code

Sample Input隊列

4
8
4 1 3 2 2 1 0 3
5 3 6 4 2 1 7 6
8
3 3 2 0 5 0 3 6
4 5 2 7 7 6 7 6
8
2 2 3 3 3 0 0 2
7 4 3 6 3 2 2 5
8
5 6 5 3 3 1 2 4
6 7 7 6 5 4 3 5ip

Sample Outputci

7
1 7 6 5 2 4 3 8
8
4 6 3 1 2 5 8 7
7
3 6 7 1 5 2 8 4
0
1 2 3 4 5 6 7 8

Source
2015 Multi-University Training Contest 6
ZX寫的優先隊列,但是是弱弱不太會運算符重載

#include <map>
#include <list>
#include <climits>
#include <cmath>
#include <queue>
#include <stack>
#include <string>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
using namespace std;
#define eps 1e-9
#define LL long long
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define CRR fclose(stdin)
#define CWW fclose(stdout)
#define RR freopen("input.txt","r",stdin)
#define WW freopen("output.txt","w",stdout)
const int Max = 100100;
const int Mod = 1000000007;
struct node
{
    int x;
    int y;
    int num;
}s[Max];
int vis[Max];
bool vist[Max];
bool cmp(node a,node b)
{
    if(a.x<b.x||(a.x==b.x&&a.y<b.y))
    {
        return true;
    }
    return false;
}
bool operator < (node a,node b)
{
    return a.y>b.y;
}
int main()
{
    int n;
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        memset(vist,false,sizeof(vist));
        for(int i=0;i<n;i++)
        {
            scanf("%d",&s[i].x);
            s[i].num=i+1;
        }
        for(int i=0;i<n;i++)
        {
            scanf("%d",&s[i].y);
        }
        sort(s,s+n,cmp);
        priority_queue<node>Q;
        int sum=0;
        int i=0;
        node a;
        while(1)    
        {
            while(i<n&&s[i].x<=sum)
            {
                Q.push(s[i++]);
            }
            while(!Q.empty()&&Q.top().y<sum)
            {
                Q.pop();
            }
            if(!Q.empty())
            {

                a=Q.top();
                Q.pop();
                vis[sum++]=a.num;
                vist[a.num]=true;
            }
            else
            {
                break;
            }
        }
        printf("%d\n",sum);
        for(i=1;i<=n;i++)
        {
            if(!vist[i])
            {
                vis[sum++]=i;
            }
        }
        for(i=0;i<sum;i++)
        {
            if(i)
            {
                printf(" ");
            }
            printf("%d",vis[i]);
        }
        printf("\n");
    }
    return 0;
}
相關文章
相關標籤/搜索