PAT 甲級 1068 Find More Coins (30 分) (dp,01揹包問題記錄最佳選擇方案)***

1068 Find More Coins (30 分)
 

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 1 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.html

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤, the total number of coins) and M (≤, the amount of money Eva has to pay). The second line contains Nface values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.ios

Output Specification:

For each test case, print in one line the face values V1​​V2​​Vk​​ such that V1​​+V2​​++Vk​​=M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output "No Solution" instead.數組

Note: sequence {A[1], A[2], ...} is said to be "smaller" than sequence {B[1], B[2], ...} if there exists k1 such that A[i]=B[i] for all i<k, and A[k] < B[k].flex

Sample Input 1:

8 9
5 9 8 7 2 3 4 1

Sample Output 1:

1 3 5

Sample Input 2:

4 8 7 2 4 3 

Sample Output 2:

No Solution

 

題意:ui

用n個硬幣買價值爲m的東西,輸出使用方案,使得正好幾個硬幣加起來價值爲m。從小到大排列,輸出最小的那個排列方案spa

題解:code

  這是一道01揹包問題,解題時注意題意的轉化:htm

  • 能夠將每一個coin都當作value和weight都相同的物品
  • 要求所付的錢剛恰好,至關於要求揹包必須恰好塞滿,且價值最大。(限制揹包體積至關於限制coin的總和不能超過所要付的錢,在此條件下求coin組合的最大值,若是這個最大值恰好等於要付的錢,則有解,此時揹包也恰好處於塞滿狀態,不然無解)
  • 最後要求從小到大輸出coin的組合,且有多解時輸出最小的組合。這是此題的難點所在,咱們應該將coin從大到小排序,在放進揹包時也從大到小逐個檢查物品,更新揹包價值的條件是在加入一個新的物品後,價值>=原價值,注意此時等號的意義,因爲物品是從大到小排序的,若是一個新的物品的加入能夠保證價值和原來相同,則此時必定是發現了更小的組合。
  做者:cheerss
  連接:https://www.jianshu.com/p/20dac38241a5
  來源:簡書
  著做權歸做者全部。商業轉載請聯繫做者得到受權,非商業轉載請註明出處。
 
  想到了揹包和dp,可是一時間忘記怎麼記錄路徑了。。。只好看別人的了,之後要回來回顧一下。。。。用數組標記的方式記錄選擇路徑。
  問題的難點在於輸出最小序列,一開始從小到大排了,原來應該從大到小排。由於先輸出的是最後選的,越到後面選擇越是小的。
 

AC代碼:blog

#include<iostream>
#include<queue>
#include<algorithm>
using namespace std;
int dp[101];//bags[i]面值不大於i的最大的面值和
bool choice[10001][101];
int cmp(int a, int b){return a > b;}
int main(){
    int w[10001];
    int n,m;
    cin>>n>>m;
    for(int i=1;i<=n;i++){
        cin>>w[i];
    }
    sort(w+1,w+1+n,cmp);
    for(int i=1;i<=n;i++){
        for(int j=m;j>=w[i];j--){ //之因此要反着來,和揹包問題的更新規則有關
            if(dp[j-w[i]]+w[i]>=dp[j]){//等號必須取到,不然輸出的解是最大的sequence
                choice[i][j]=true;//跟蹤哪一個物品被選擇了
                dp[j]=dp[j-w[i]]+w[i];
            }
        }
    }
    if(dp[m] != m) printf("No Solution");
    else{  //下面是輸出最優組合的過程,其實和揹包問題的更新規則有關,就是沿着選出解的路徑,反着走回去,就找到了全部被選擇的數字。
        int i=n,j=m;
        while(1){
            if(choice[i][j]==true){
                cout<<w[i];
                j-=w[i];
                if(j!=0) cout<<" ";
            }
            i--;
            if(j==0||i==0) break;
        }
    }
    return 0;
}
相關文章
相關標籤/搜索