【貪心算法】POJ-1017

1、題目

Description

A factory produces products packed in square packets of the same height h and of the sizes 11, 22, 33, 44, 55, 66. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.算法

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 11 to the biggest size 66. The end of the input file is indicated by the line containing six zeros.學習

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.spa

Sample Input

0 0 4 0 0 1
7 5 1 0 0 0
0 0 0 0 0 0rest

Sample Output

2
1code

2、思路&心得

  • 題目大意爲共有1 * 一、2 * 2...6 * 6的產品各a[i]個,包裝袋大小固定爲6 * 6,問最少最要多少個包裝袋,能夠把每一個訂單中全部產品包裝起來。
  • 這個題目有點相似硬幣問題,在選擇時從最大的6 * 6的產品開始依次往小進行計算。對於6 * 六、5 * 五、4 * 4的產品,各須要包裝袋a[6]、a[5]、a[4]個,其中放置5 * 5產品的包裝袋能夠額外裝11個1 * 1的產品,放置4 * 4產品的能夠額外裝5個2 * 2的產品;對於3 * 3的產品比較特殊,對4取模後,根據餘數0、一、二、3分四種狀況進行判斷,每次選擇時儘量得裝入更多的2 * 2的產品再裝入1 * 1的產品;對於2 * 2和1 * 1的產品判斷較爲簡單,再也不多說。
  • 在作這題時剛開始有點看不懂題意,便看了下discuss區,發現全部人都說這題很是很是難以及細節不少,致使不敢輕易下手。可是思路想清,WA了一兩次以後,便AC了,好像也沒想象中的那麼難。
  • 在網上觀摩到大神的極短代碼,算法思想很是精闢,特另附上,以供學習。

3、代碼

個人渣解法:ip

#include<cstdio>

int a[7];

int ans;

void solve() {
    ans += (a[4] + a[5] + a[6]);
    a[1] -= a[5] * 11;
    a[2] -= a[4] * 5;
    if (a[2] < 0) {
        a[1] += a[2] * 4;
    }
    ans += (a[3] / 4 + 1);
    switch (a[3] % 4) {
        case 0: {
            ans --;
            break;
        }
        case 1: {
            if (a[2] > 0) {
                a[2] -= 5;
                if (a[2] < 0) {
                    a[1] += a[2] * 4;
                }
                a[1] -= 7;
            } else {
                a[1] -= 27;
            }
            break;
        } 
        case 2: {
            if (a[2] > 0) {
                a[2] -= 3;
                if (a[2] < 0) {
                    a[1] += a[2] * 4;
                }
                a[1] -= 6;
            } else {
                a[1] -= 18;
            }
            break;
        }
        case 3: {
            if (a[2] > 0) {
                a[2] -= 1;
                a[1] -= 5;
            } else {
                a[1] -= 9;
            }
            break;
        }
    }
    if (a[2] > 0) {
        ans += a[2] / 9;
        if (a[2] % 9 > 0) {
            ans ++;
            a[1] -= (9 - a[2] % 9) * 4;         
        }
    }
    if (a[1] > 0) {
        ans += (a[1] + 35) /36;
    }
    printf("%d\n", ans);
}

int main () {
    while (1) {
        ans = 0;
        for (int i = 1; i <= 6; i ++) {
            scanf("%d", &a[i]);
        }
        if (!a[1] && !a[2] && !a[3] && !a[4] && !a[5] && !a[6]) break;
        solve();
    }
    return 0;
}

大神的精闢解法:ci

#include<stdio.h>
int main()
{
    int n,a,b,c,d,e,f,x,y;
    int u[4]={0,5,3,1};
    while(1)
    {
        scanf("%d%d%d%d%d%d",&a,&b,&c,&d,&e,&f);
        if(a==0&&b==0&&c==0&&d==0&&e==0&&f==0)
            break;
        n=d+e+f+(c+3)/4;
        y=5*d+u[c%4];//在已有n個的狀況下,能裝下y個2*2的
        if(b>y)
            n+=(b-y+8)/9;//把多的2*2的弄進來
        x=36*n-36*f-25*e-16*d-9*c-4*b;
        if(a>x)
            n+=(a-x+35)/36;//把1*1的弄進來
        printf("%d\n",n);
    }
    return 0;
}
相關文章
相關標籤/搜索