WustOJ 1575 Gingers and Mints(快速冪 + dfs )

1575: Gingers and Mints

Time Limit: 1 Sec  Memory Limit: 128 MB   64bit IO Format: %lld
Submitted: 24  Accepted: 13
[Submit][Status][Web Board]

Description

fcbruce owns a farmland, the farmland has n * m grids. Some of the grids are stones, rich soil is the rest. fcbruce wanna plant gingers and mints on his farmland, and each plant could occupy area as large as possible. If two grids share the same edge, they can be connected to the same area. fcbruce is an odd boy, he wanna plant gingers, which odd numbers of areas are gingers, and the rest area, mints. Now he want to know the number of the ways he could plant.

 

Input

The first line of input is an integer T (T < 100), means there are T test cases.
For each test case, the first line has two integers n, m (0 < n, m < 100).
For next n lines, each line has m characters, 'N' for stone, 'Y' for rich soil that is excellent for planting.
 

 

Output

For each test case, print the answer mod 1000000007 in one line. php

 

Sample Input

 
2
3 3
YNY
YNN
NYY
3 3
YYY
YYY
YYY

 

Sample Output

4
1

 

HINT

 

For the first test case, there are 3 areas for planting. We marked them as A, B and C. fcbruce can plant gingers on A, B, C or ABC. So there are 4 ways to plant gingers and mints.網絡


 

 

Source

Author

fcbruce設計

思路:
1.先用DFS求出聯通塊個數。
2.再根據數學知識 C{n,1} + C{n,3} + C{n,5} + ... = 2^(n-1) 用快速冪求出。
#include<cstdio>
#include<cstring>
using namespace std;

#define maxn 200
char pic[maxn][maxn];
int vis[maxn][maxn];
int dx[4] = {-1,1,0,0};
int dy[4] = {0,0,-1,1};
int n,m;

void dfs(int x, int y)
{
    for(int i = 0; i < 4; i++)
    {
        int nx = x + dx[i];
        int ny = y + dy[i];
        if(!vis[nx][ny] && pic[nx][ny] == 'Y' && nx >= 0 && nx < n && ny >= 0 && ny < m)
        {
            vis[nx][ny] = 1;
            dfs(nx,ny);
        }
    }
}
int pow_mod(int a,int n,int m)
{

    if(n==0)
    return  1;
    int x=pow_mod(a,n/2,m);
    long long ans=(long long)x*x%m;
    if(n%2==1)
        ans=ans*a%m;
    return (int )ans;
}

int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d", &n, &m);
        memset(vis, 0, sizeof vis);
        for(int i = 0; i < n; i++)
            scanf("%s", pic[i]);
        int cnt = 0;
        for(int i = 0; i < n; i++)
            for(int j = 0; j < m; j++)
            {
                if(!vis[i][j] && pic[i][j] == 'Y')
                {
                    vis[i][j] = 1;
                    cnt++;
                    dfs(i,j);
                }
            }
            printf("%d\n",pow_mod(2,cnt-1,1000000007));
    }
    return 0;
}
相關文章
相關標籤/搜索