POJ 1012 Joseph

Joseph
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 44650   Accepted: 16837

Descriptionide

The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved. 

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy. 

Inputspa

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

Outputcode

The output file will consist of separate lines containing m corresponding to k in the input file.

Sample Inputblog

3
4
0

Sample Outputip

5
30
題目大意:約瑟夫問題,總共有2 * k我的報數,前面k個是好人,後面k個是壞人,報道m的人要死去,問當m爲什麼值時,壞人所有死去以前不會有好人死去。
解題方法:從1開始枚舉m的值,遇到不知足的則將m加一再次枚舉,知道知足爲止。
#include <stdio.h>

int main()
{
    int people[50] = {0}, k, Joseph[14] = {0};//Joseph用於打表,否則超時
    while(scanf("%d", &k) != EOF && k != 0)
    {
        if (Joseph[k] != 0)
        {
            printf("%d\n", Joseph[k]);
            continue;
        }
        int n = 2 * k;
        int m = 1;
        people[0] = 0;//people[0] = 0表示編號從0開始
        for (int i = 1; i <= k; i++)
        {
            //每次枚舉完畢將剩下的人按從0到n - i編號,只要好人沒有殺掉,則前面k - 1個編號是不變的
            people[i] = (people[i - 1] + m - 1) % (n - i + 1);
            if (people[i] < k)//第k我的的編號爲k - 1,因此這裏是<而不是<=
            {
                i = 0 ;
                m++;
            }
        }
        Joseph[k] = m;
        printf("%d\n", m);
    }
    return 0;
}
相關文章
相關標籤/搜索