FatMouse's Speed——J

                                                       J. FatMouse's Speed

FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
 

Input

Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed. 
 

Output

Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that 

W[m[1]] < W[m[2]] < ... < W[m[n]]

and 

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 
 

Sample Input

6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900

Sample Output

4
4
5
9
7

題意:node

要求找到的體重遞增,速度遞減的老鼠,而且輸出最長的長度數,並且輸出各自的序列數。(Special Judge  說明答案不惟一,只要輸出的答案正確就能夠)ios

 

 

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
    int num,w,s;
}a[1005];
int cmp(node c,node d)  {return c.w<d.w;}
int x,y,k,t[1005],r[1005];
int main()
{
    int i,j,L,p=0,ant=1,er=1;
    k=0;
    memset(t,0,sizeof(t));
    while(cin>>x>>y)
    {
        a[k].num=k+1;
        a[k].w=x;
        a[k].s=y;
        k++;
    }
    sort(a,a+k,cmp);
    for(i=0;i<k;i++) t[i]=1;
    for(i=1;i<k;i++)
    {
        for(j=0;j<i;j++)
        {
            if(a[j].s>a[i].s&&a[j].w<a[i].w&&t[i]<t[j]+1)
                t[i]+=1;
        }
    }
       for(i=0;i<k;i++)  p=max(p,t[i]);
       cout<<p<<endl;
       for(i=0;i<k;i++)
       {
           if(p==t[i]) j=i;
       }
       int temp=j;
       r[er++]=a[j].num;
       for(L=j-1;L>=1;L--)
       {
           if(t[L]+1==t[j]&&a[L].s>a[temp].s)
           {
               ant++;
               r[er++]=a[L].num;
               t[j]=t[L];
               temp=L;
           }
           if(ant==p) break;
       }
       for(i=er-1;i>0;i--)  cout<<r[i]<<endl;
   return 0;
}
相關文章
相關標籤/搜索