MPI Maelstrom - POJ1502最短路

Time Limit: 1000MS Memory Limit: 10000K

Description

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee’s research advisor, Jack Swigert, has asked her to benchmark the new system. Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,」 Valentine told Swigert. 「Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.」 node

「How is Apollo’s port of the Message Passing Interface (MPI) working out?」 Swigert asked. markdown

Not so well,'' Valentine replied.To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.」 ui

「Is there anything you can do to fix that?」 spa

Yes,'' smiled Valentine.There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.」 rest

「Ah, so you can do the broadcast as a binary tree!」 code

「Not really a binary tree – there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don’t necessarily arrive at the destinations at the same time – there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.」
Inputorm

The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100. ip

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j. input

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied. string

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.

Output

Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.

Sample Input

5
50
30 5
100 20 50
10 x x 10

Sample Output

35

Source

East Central North America 1996

題意:有N個通信器,他們之間有信息傳遞,可是傳遞的時間不一樣,有一個矩陣a[i,j]表示第i個通信器向第j個通信器之間傳遞信息須要的時間,x表示之間沒有信息傳遞。問從第一個通信器想其餘的通信器傳遞信息,全部通信器都接受到信息的時間

分析:單源最短路模型,求出從第一個通信器到其餘的最短的時間的最大值就是結果。

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <queue>
#include <stack>
#include <queue>
#include <vector>
#include <cmath>
#include <queue>
#include <algorithm>
#define LL long long 

using namespace std;

const int Max = 110;

const int INF = 0x3f3f3f3f;

int Map[Max][Max];

int Dis[Max];

bool vis[Max];

int n;

char str[10];

int Trans()
{
    int ans = 0;

    for(int i = 0 ;str[i]!='\0';i++)
    {
        ans =  ans*10+str[i]-'0';
    }

    return ans;
}


void SPFA()//SPFA求最短路
{
    memset(vis,false,sizeof(vis));

    memset(Dis,INF,sizeof(Dis));

    vis[1]=true;

    Dis[1]=0;

    queue<int>Q;

    Q.push(1);

    while(!Q.empty())
    {
        int u = Q.front();

        Q.pop();

        vis[u]=false;

        for(int i=1;i<=n;i++)
        {
            if(Map[u][i]+Dis[u]<Dis[i])
            {
                Dis[i] = Map[u][i]+Dis[u];

                if(!vis[i])
                {
                    vis[i]=true;

                    Q.push(i);
                }
            }
        }
    }

}


int main()
{

    int va;

    while(~scanf("%d",&n))
    {
        memset(Map,0,sizeof(Map));

        for(int i=2;i<=n;i++)
        {
            for(int j=1;j<i;j++)
            {
                scanf("%s",str);

                if(str[0]=='x')
                {
                    va=INF;
                }
                else
                {
                    va = Trans();
                }
                Map[i][j] = Map[j][i]=va;
            }
        }
        SPFA();

        int ans = 0;

        for(int i=2;i<=n;i++)
        {
            ans = max(ans,Dis[i]);
        }

        printf("%d\n",ans);
    }
    return 0;
}
相關文章
相關標籤/搜索