時間限制 測試
400 ms this
內存限制 spa
32000 kB orm
代碼長度限制 ip
16000 B 內存
判題程序 ci
Standard rem
做者 get
CHEN, Yue input
A table tennis club has N tables available to the public. The tables are numbered from 1 to N. For any pair of players, if there are some tables open when they arrive, they will be assigned to the available table with the smallest number. If all the tables are occupied, they will have to wait in a queue. It is assumed that every pair of players can play for at most 2 hours.
Your job is to count for everyone in queue their waiting time, and for each table the number of players it has served for the day.
One thing that makes this procedure a bit complicated is that the club reserves some tables for their VIP members. When a VIP table is open, the first VIP pair in the queue will have the priviledge to take it. However, if there is no VIP in the queue, the next pair of players can take it. On the other hand, if when it is the turn of a VIP pair, yet no VIP table is available, they can be assigned as any ordinary players.
Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (<=10000) - the total number of pairs of players. Then N lines follow, each contains 2 times and a VIP tag: HH:MM:SS - the arriving time, P - the playing time in minutes of a pair of players, and tag - which is 1 if they hold a VIP card, or 0 if not. It is guaranteed that the arriving time is between 08:00:00 and 21:00:00 while the club is open. It is assumed that no two customers arrives at the same time. Following the players' info, there are 2 positive integers: K (<=100) - the number of tables, and M (< K) - the number of VIP tables. The last line contains M table numbers.
Output Specification:
For each test case, first print the arriving time, serving time and the waiting time for each pair of players in the format shown by the sample. Then print in a line the number of players served by each table. Notice that the output must be listed in chronological order of the serving time. The waiting time must be rounded up to an integer minute(s). If one cannot get a table before the closing time, their information must NOT be printed.
Sample Input:
9 20:52:00 10 0 08:00:00 20 0 08:02:00 30 0 20:51:00 10 0 08:10:00 5 0 08:12:00 10 1 20:50:00 10 0 08:01:30 15 1 20:53:00 10 1 3 1 2Sample Output:
08:00:00 08:00:00 0 08:01:30 08:01:30 0 08:02:00 08:02:00 0 08:12:00 08:16:30 5 08:10:00 08:20:00 10 20:50:00 20:50:00 0 20:51:00 20:51:00 0 20:52:00 20:52:00 0 3 3 2
這題很是麻煩,坑不少,主要有如下幾點:
1.當有多個乒乓球檯空閒時,vip顧客到了會使用最小id的vip球檯,而不是最小id的球檯,測試如下用例:
2 10:00:00 30 1 12:00:00 30 1 5 1 3
輸出正確結果應爲:
10:00:00 10:00:00 0
12:00:00 12:00:00 0
0 0 2 0 0
2.題目要求每對顧客玩的時間不超過2小時,那麼當顧客要求玩的時間>2小時的時候,應該截斷控制,測試如下用例:
2 18:00:00 180 1 20:00:00 60 1 1 1 1
輸出的正確結果應爲:
18:00:00 18:00:00 0
20:00:00 20:00:00 0
2
3.雖然題目中保證客戶到達時間在08:00:00到21:00:00之間,可是根據最後的8個case來看,裏面仍是有不在這個時間區間內到達的顧客,因此建議仍是稍加控制,測試如下用例:
1 21:00:00 80 1 1 1 1
輸出的正確結果應爲:
0
4.題目中說的round up to an integer minutes是嚴格的四捨五入,須要以下作:
wtime = (stime - atime + 30) / 60
而不是:
wtime = (stime - atime + 59) / 60
(額,這個多是我本身的白癡問題,糾結了近一個小時就這個。。。)
完整經過的代碼以下(Python):
tm2secs = lambda t: t[0] * 3600 + t[1] * 60 + t[2] secs2tm = lambda s: '%02d:%02d:%02d' % (s/3600, s/60%60, s%60) N = input() players = [raw_input() for i in xrange(N)] players.sort() for i, player in enumerate(players): player = player.split() atime = tm2secs(map(int, player[0].split(':'))) ptime, isvip = map(int, player[1:]) if ptime > 120: ptime = 120 players[i] = atime, ptime, isvip N, M = map(int, raw_input().split()) vips = map(int, raw_input().split()) now = tm2secs((8,0,0)) create_table = lambda i: [0, True if i+1 in vips else False, now] tables = [create_table(i) for i in xrange(N)] def get_a_table(atime): for table in tables: if table[-1] <= atime: return table def get_a_vip_table(atime): for table in tables: if table[-1] <= atime and table[1]: return table def print_record(atime, stime): wtime = (stime - atime + 30) / 60 atime = secs2tm(atime) stime = secs2tm(stime) print atime, stime, wtime def serv_table(table, atime, ptime): table[0] += 1 table[-1] = max(table[-1], atime) print_record(atime, table[-1]) table[-1] += ptime * 60 def get_earliest_table(): tmp = [table[-1] for table in tables] return tables[tmp.index(min(tmp))] def get_a_vip_player(index, table): for player in players[index+1:]: if player[-1] and player[0] <= table[-1]: players.remove(player) players.insert(index, player) return player for i, player in enumerate(players): atime, ptime, isvip = player if atime >= tm2secs((21, 0, 0)): break if isvip: vip_table = get_a_vip_table(atime) if vip_table: serv_table(vip_table, atime, ptime) continue table = get_a_table(atime) if table: serv_table(table, atime, ptime) continue else: table = get_earliest_table() if table[-1] >= tm2secs((21, 0, 0)): break if not isvip and table[1]: vip_player = get_a_vip_player(i, table) if vip_player: atime, ptime, isvip = vip_player serv_table(table, atime, ptime) continue serv_table(table, atime, ptime) for table in tables: print table[0],