編筐

須要的時候,就把一個個大小差一圈的筐疊上去,使得從上往下看時,邊筐花色交錯。這個工做如今要讓計算機來完成,得看你的了。
ios

Input
輸入是一個個的三元組,分別是,外筐尺寸n(n爲知足0<n<80的奇整數),中心花色字符,外筐花色字符,後兩者都爲ASCII可見字符;
spa

Output
輸出疊在一塊兒的筐圖案,中心花色與外筐花色字符從內層起交錯相疊,多筐相疊時,最外筐的角老是被打磨掉。疊筐與疊筐之間應有一行間隔。
ci

Sample Input
11 B A
5 @ W
io

Sample Output
AAAAAAAAA
ABBBBBBBBBA
ABAAAAAAABA
ABABBBBBABA
ABABAAABABA
ABABABABABA
ABABAAABABA
ABABBBBBABA
ABAAAAAAABA
ABBBBBBBBBA
AAAAAAAAA stream

@@@
@WWW@
@W@W@
@WWW@
@@@ 計算機

#include <iostream>
using namespace std;
char str[100][100];
int n;
void cc(int m,int th,char a)
{
int i;
for(i=th;i<=n+1-th;i++)
{
str[i][th]=a;
str[i][n+1-th]=a;
}
for(i=th;i<=n+1-th;i++)
{
str[th][i]=a;
str[n+1-th][i]=a;
}
}
int main()
{
int i,j,m,k=0;
char str1,str2,str0;
while(cin>>n>>str1>>str2)
{
if(k!=0) cout<<endl;
if(n==1) {cout<<str1<<endl;k++;continue;}
m=n/2+1;
for(i=1;i<=m;i++)
{
if(i%2==0&&m%2==0) str0=str1;
if(i%2!=0&&m%2==0) str0=str2;
if(i%2==0&&m%2!=0) str0=str2;
if(i%2!=0&&m%2!=0) str0=str1;
cc(m,i,str0);
}
str[1][1]=str[1][n]=' ';
str[n][1]=str[n][n]=' ';
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
cout<<str[i][j];
cout<<endl;
}
k++;
}
return 0;
}while

相關文章
相關標籤/搜索