A1008. Elevator (20)

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.ios

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.less

Input Specification:ui

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.spa

Output Specification:code

For each test case, print the total time on a single line.blog

Sample Input:ci

3 2 3 1

Sample Output:input

41
// hahaha.cpp : 定義控制檯應用程序的入口點。
//

#include <stdafx.h>
#include <stdio.h>
#include <iostream>
#include <vector>
#include <map>
#include <string>
#include <cstdio>
#include <set>
#include <algorithm>
#include <string.h>
using namespace std;

const int maxn=110;


int main()
{
   int n;
   int a[maxn];
   scanf("%d",&n);
   for(int i=0;i<n;i++)
       {
       scanf("%d",&a[i]);
       }
   int time=0;
   int tmp=0;
   for(int i=0;i<n;i++)
       {
       if(a[i]>tmp)
           {
           time=time+(a[i]-tmp)*6;
           
          
           }else if(a[i]<tmp)
           {
             time=time+(tmp-a[i])*4;
             
             }
        time+=5;
            tmp=a[i];
       }
   printf("%d",time);
    return 0;
}
相關文章
相關標籤/搜索