數據類型的自定義(1)

Description

某小組5人,每人三項數據:姓名、年齡、分數,鍵盤輸入這些人的數據,求小組的平均分及成績最高者的數據函數

說明:年齡和分數都是整數spa

Input

鍵盤輸入5我的的數據排序

Output

輸出平均分及成績最高者的數據ip

注:後臺數據能夠保證平均分是一個整數,沒有小數input

Sample Input

aaa 18 90 bbb 19 80 ccc 19 80 ddd 18 60 eee 18 70

Sample Output

76 aaa,18,90
 
 

#include<stdio.h>
struct grade
{
char a[5];
int age;
int grade;
};
int main()
{
struct grade A[5];
int i;
for(i=0;i<5;i++)
{
scanf("%s",A[i].a);
scanf("%d%d",&A[i].age,&A[i].grade);
}
int sum=0;
for(i=0;i<5;i++)
{
sum+=A[i].grade;
}
sum=sum/5;
int k=0;
for(i=0;i<5;i++)
{
if(A[i].grade>A[k].grade)
{
k=i;
}
}
printf("%d\n",sum);
printf("%s,%d,%d",A[k].a,A[k].age,A[k].grade);
return 0;
}io

 

Description

寫兩個函數:class

一、一個函數中輸入10個學生的數據,每一個人都包括三項基本資料:學號,生日,分數(整數)。後臺

二、另外一個函數能夠按照分數由高到低的順序將每一個人的資料排列輸出。im

主函數已在後臺,提交時會自動添加在你的代碼以後。數據

主函數以下:

int main()

{

       struct student s[10];

       input(s,10);

       sort(s,10);

       return 0;

}

請編寫所需代碼。

 

Input

10個學生的數據,每人一行

Output

輸出排序後的數據,每人一行

Sample Input

5 1990 10 1 86 3 1992 1 5 90 8 1991 3 1 70 9 1990 5 5 65 1 1991 6 22 89 4 1992 12 31 77 2 1990 1 1 87 6 1989 6 6 92 10 1990 8 1 88 7 1992 3 9 82

Sample Output

6,1989/6/6,92 3,1992/1/5,90 1,1991/6/22,89 10,1990/8/1,88 2,1990/1/1,87 5,1990/10/1,86 7,1992/3/9,82 4,1992/12/31,77 8,1991/3/1,70 9,1990/5/5,65  
 

#include<stdio.h>

struct birthday
{
int year;
int month;
int day;
};
struct student
{
int num;
struct birthday t;
int grade;
};

void input(struct student *p,int n)
{
int i;
for(i=0;i<n;i++)
{
scanf("%d",&p->num);
scanf("%d %d %d",&p->t.year,&p->t.month,&p->t.day);
scanf("%d",&p->grade);
p++;
}

}

void sort(struct student *p,int n)
{
int i;
struct student temp;
int j;
for(i=0;i<n-1;i++)
{
for(j=0;j<n-i-1;j++)
{
if((p+j)->grade<(p+j+1)->grade)
{
temp=*(p+j);
*(p+j)=*(p+j+1);
*(p+j+1)=temp;
}
}
}

for(i=0;i<n;i++)
{
printf("%d,%d/%d/%d,%d\n",p->num,p->t.year,p->t.month,p->t.day,p->grade);
p++;
}
}
int main()
{
struct student s[10];
input(s,10);
sort(s,10);
return 0;
}

 

Description

主函數以下:

int main()
{
 struct time a,b,c;
 scanf("%d%d%d",&a.h,&a.m,&a.s);
 scanf("%d%d%d",&b.h,&b.m,&b.s);
 sub(&a,&b,&c);
 printf("%d:%d\'%d\"\n",c.h,c.m,c.s);
 return 0;
}

主函數已在後臺,您只需提交結構體定義以及sub函數的定義便可,系統會自動將主函數代碼追加到您提交(修改)的代碼以後。

 

Input

輸入6個整數做爲兩個時間的小時、分鐘、秒

Output

 

 

 

輸出兩個時間相加以後的總時間 

Sample Input

1 35 40 2 40 50

Sample Output

4:16'30"
 

#include<stdio.h>

struct time
{
int h;
int m;
int s;
};
void sub(struct time *a,struct time *b,struct time *c)
{
c->s=a->s+b->s;
c->m=a->m+b->m;
c->h=a->h+b->h;
if(c->s>=60)
{
c->s-=60;
c->m+=1;
}
if(c->m>=60)
{
c->m-=60;
c->h+=1;
}

}
int main()
{
struct time a,b,c;
scanf("%d%d%d",&a.h,&a.m,&a.s);
scanf("%d%d%d",&b.h,&b.m,&b.s);
sub(&a,&b,&c);
printf("%d:%d\'%d\"\n",c.h,c.m,c.s);
return 0;
}

 

Description

某小組5人,每人三項數據:姓名、年齡、考試分數,鍵盤輸入這些人的數據,輸出小組中成績最高者的數據

說明:年齡和分數都是整數,姓名中沒有空格

Input

輸入5我的的數據

Output

輸出成績最高者的信息

Sample Input

aaa 18 92 bbb 19 80 ccc 19 80 ddd 18 60 eee 18 70

Sample Output

aaa,18,92
 

#include<stdio.h>


struct grade
{
char a[5];
int age;
int grade;
};
int main()
{
struct grade A[5];
int i;
for(i=0;i<5;i++)
{
scanf("%s",A[i].a);
scanf("%d %d",&A[i].age,&A[i].grade);
}
int k=0;
for(i=0;i<5;i++)
{
if(A[i].grade>A[k].grade)
{
k=i;
}
}
printf("%s,%d,%d",A[k].a,A[k].age,A[k].grade);
}

相關文章
相關標籤/搜索