I Hate It(線段樹區間最值,單點更新)-------------藍橋備戰系列

不少學校流行一種比較的習慣。老師們很喜歡詢問,從某某到某某當中,分數最高的是多少。 
這讓不少學生很反感。 

無論你喜不喜歡,如今須要你作的是,就是按照老師的要求,寫一個程序,模擬老師的詢問。固然,老師有時候須要更新某位同窗的成績。node

Inputios

本題目包含多組測試,請處理到文件結束。 
在每一個測試的第一行,有兩個正整數 N 和 M ( 0<N<=200000,0<M<5000 ),分別表明學生的數目和操做的數目。 
學生ID編號分別從1編到N。 
第二行包含N個整數,表明這N個學生的初始成績,其中第i個數表明ID爲i的學生的成績。 
接下來有M行。每一行有一個字符 C (只取'Q'或'U') ,和兩個正整數A,B。 
當C爲'Q'的時候,表示這是一條詢問操做,它詢問ID從A到B(包括A,B)的學生當中,成績最高的是多少。 
當C爲'U'的時候,表示這是一條更新操做,要求把ID爲A的學生的成績更改成B。 ide

Output測試

對於每一次詢問操做,在一行裏面輸出最高成績。ui

Sample Inputspa

5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5

Sample Outputcode

5
6
5
9


        
  

Hintci

Huge input,the C function scanf() will work better than cin
        
 代碼:
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<vector>
#include<cmath>

const int maxn=2e5+5;
typedef long long ll;
using namespace std;
struct node
{
	ll l,r,maxx;
}tree[maxn<<2];
void pushup(int m)
{
	tree[m].maxx=max(tree[m<<1].maxx,tree[m<<1|1].maxx); 
}

void build(int m,int l,int r)
{
	tree[m].l=l;
	tree[m].r=r;
	if(l==r)
	{
		scanf("%lld",&tree[m].maxx);
		return;
	}
	int mid=(l+r)>>1;
	build(m<<1,l,mid);
	build(m<<1|1,mid+1,r);
	pushup(m);
}
void update(int m,int index,int val)
{

	if(tree[m].l==index&&tree[m].r==index)    
	{
		tree[m].maxx=val;
		return;
	}
	int mid=(tree[m].l+tree[m].r)>>1;
	if(index<=mid)
	{
		update(m<<1,index,val);
	}
	else 
	{
		update(m<<1|1,index,val);
	}
	pushup(m);
}
ll  query(int m,int l,int r)
{
	if(tree[m].l==l&&tree[m].r==r)
	{
		return tree[m].maxx;
	}
	int mid=(tree[m].l+tree[m].r)>>1;
	ll res=0;
	if(r<=mid)
	{
		res=query(m<<1,l,r);
	}
	else if(l>mid) 
	{
		res=query(m<<1|1,l,r);
	}
	else
	{
		res=max(query(m<<1,l,mid),query(m<<1|1,mid+1,r));
	}
	return res;
}
int main()
{
  
    int n,m;
    while(cin>>n>>m)
    {
	
    build(1,1,n);
    char op[2];
    int l,r,pos,val;
    for(int t=0;t<m;t++)
    {
    	scanf("%s",op);
    	if(op[0]=='Q')
		{
			scanf("%d%d",&l,&r);
			printf("%lld\n",query(1,l,r));
		} 
		else if(op[0]=='U')
		{
			scanf("%d%d",&pos,&val);
			update(1,pos,val);
		 } 
	}
	}
    
	return 0;
}
相關文章
相關標籤/搜索