配置多臺三層交換VLAN間相互通訊

本實驗需求:
 經過在SW100 來建立VLAN 100 ,sw2 上建立VLAN 200,由於VLAN100和VLAN200由於業務上的關係,須要兩臺PC之間相互通訊,保證不一樣VLAN之間能夠互相訪問。 本實驗將給您詳細闡述實現方法,將用到諸多交換知識點。

實驗拓撲:
p_w_picpath
 
實驗過程 第一步 SW100基礎配置
SW100>
SW100> enable
SW100#conf t
Enter configuration commands, one per line. End with CNTL/Z.
SW100(config)# no ip do lo
SW100(config)# line con 0
SW100(config-line) #no exec-t
SW100(config-line)# logg syn
SW100(config-line)# exit
SW100(config)# username admin privilege 15 password admin
SW100(config)# line vty 0 15
SW100(config-line)# login local
SW100(config-line)# int f0/24
// 配置把二層接口更改成三層接口
SW100(config-if)# no switchport
SW100(config-if)# ip add 12.0.0.1 255.255.255.0
00:02:57: %LINK-3-UPDOWN: Interface FastEthernet0/24, changed state to up
00:02:58: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to up
SW100(config-if)# no sh
第二步 SW200 基礎配置
Switch> enable
Switch# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# host SW200
SW200(config)# no ip do lo
SW200(config)# line con 0
SW200(config-line)# no exec-t
SW200(config-line)# logg syn
SW200(config-line)# exit
SW200(config)# username admin privilege 15 password admin
SW200(config)# line vty 0 15
SW200(config-line)# login local
SW200(config-line)# int f0/24
// 把二層端口改變成三層接口
SW200(config-if)# no switchport
SW200(config-if)#ip add 12.0.0.2 255.2
00:03:40: %LINK-3-UPDOWN: Interface FastEthernet0/24, changed state to up
00:03:41: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to up
SW200(config-if)# ip add 12.0.0.2 255.255.255.0
SW200(config-if)# no sh
SW200(config-if)# exit
第三步 完整SW1上VLAN配置
//建立VLAN 100
SW100(config)# vlan 100
// 給VLAN 命名爲100
SW100(config-vlan)# name 100
// 進入f0/13 接口模式下,把f0/13 接口劃分到VLAN100
SW100(config-vlan)# int f0/13
SW100(config-if)# switchport mode access
SW100(config-if)# switchport access vlan 100
SW100(config-if)#exit
SW100(config)# int f0/13
// 由於此接口鏈接的終端設備,故能夠關閉生成樹的選舉,開啓快速端口特性
SW100(config-if)# spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single
host. Connecting hubs, concentrators, switches, bridges, etc... to this
interface when portfast is enabled, can cause temporary bridging loops.
Use with CAUTION
%Portfast has been configured on FastEthernet0/15 but will only
have effect when the interface is in a non-trunking mode.
SW100(config-if)#exit
00:05:40: %SYS-5-CONFIG_I: Configured from console by console
//查看VLAN信息
SW100# show vlan brief
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4
Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/14, Fa0/15, Fa0/16, Fa0/17
Fa0/18, Fa0/23, Gi0/1, Gi0/2
100 100 active Fa0/13
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
第四步 完成SW200上VLAN配置
SW200(config)# vlan 200
SW200(config-vlan)# name 200
SW200(config-vlan)# int f0/15
SW200(config-if)# switchport mode access
SW200(config-if)# switchport access vlan 200
SW200(config-if)# exit
SW200(config)# int f0/15
SW200(config-if)# spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single
host. Connecting hubs, concentrators, switches, bridges, etc... to this
interface when portfast is enabled, can cause temporary bridging loops.
Use with CAUTION
%Portfast has been configured on FastEthernet0/15 but will only
have effect when the interface is in a non-trunking mode.
SW100# show vlan brief
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4
Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/14, Fa0/15, Fa0/16, Fa0/17
Fa0/18, Fa0/23, Gi0/1, Gi0/2
200 200 active Fa0/15
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
第五步 在SW100上建立SVI(交換虛擬接口),並給SW100所鏈接PC配置IP地址爲192.168.0.100,網關192.168.0.1(PC配置IP地址,網關,實驗手冊內容略過)
SW100# conf t
Enter configuration commands, one per line. End with CNTL/Z.
//進入VLAN 100
SW100(config) #int vlan 100
// 配置VLAN100 ,IP 地址,這裏的IP 地址,就是F0/13 接口下PC 所指的網關地址
SW100(config-if)# ip add 192.168.0.1 255.255.255.0
SW100(config-if)# no sh
SW100(config-if)# end
00:06:09: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state to up
// 從SW100 上測試能夠ping 通本VLAN 下PC
SW100# ping 192.168.0.100
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.100, timeout is 2 seconds:
!!!!!
第六步 在SW200上建立SVI(交換機虛擬接口),並給SW200所鏈接PC配置IP地址爲172.16.0.100,網關172.16.0.1(PC配置IP地址,實驗手冊內容略過)
SW200(config-if)# exit
SW200(config)# int vlan 200
SW200(config-if)# ip add 172.16.0.1 255.255.255.0
00:04:41: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan200, changed state to up
SW200(config-if)# no sh
SW200(config-if)# end
00:04:52: %SYS-5-CONFIG_I: Configured from console by console
SW200# ping 172.16.0.200
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.200, timeout is 2 seconds:
!!!!!
第七步 在SW100 上開啓路由功能,並運行動態路由協議
SW100# conf t
Enter configuration commands, one per line. End with CNTL/Z.
// 開啓三層交換路由功能,默認是關閉的
SW100(config)# ip routing
SW100(config)# router ospf 100
SW100(config-router)# net 12.0.0.1 0.0.0.255 a 0
SW100(config-router)# net 192.168.0.1 0.0.0.255 a 0
SW100(config-router)# end
SW100#
00:08:11: %SYS-5-CONFIG_I: Configured from console by console


第八步 在SW200 上開啓路由功能,並運行動態路由協議
SW200# conf t
Enter configuration commands, one per line. End with CNTL/Z.
// 注意:若是沒有開啓路由功能,直接運行路由協議,將提示以下的錯誤信息
SW200(config)# router ospf 200
IP routing not enabled
SW200(config)# ip routing
SW200(config)# router ospf 200
SW200(config-router)# net 12.0.0.2 0.0.0.255 a 0
SW200(config-router)# net 172.16.0.2 0.0.0.255 a 0
SW200(config-router)# end
00:05:27: %OSPF-5-ADJCHG: Process 200, Nbr 192.168.0.1 on FastEthernet0/24 from LOADING to FULL, Loading Done
/ / 查看路由表,觀察經過OSPF 學習到路由條目
SW200# show ip ro
00:05:33: %SYS-5-CONFIG_I: Configured from console by console
SW200#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 1 subnets
C 172.16.0.0 is directly connected, Vlan200
O 192.168.0.0/24 [110/2] via 12.0.0.1, 00:00:02, FastEthernet0/24
12.0.0.0/24 is subnetted, 1 subnets
C 12.0.0.0 is directly connected, FastEthernet0/24
// 測試IP 連通性
SW200# ping 12.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
SW200# ping 192.168.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
SW200# ping 192.168.0.100
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.100, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
SW200#
第九步 在PC2 用ping命令測試到PC1,測試vlan200是否能夠和VLAN 100 PING通,測試結果全網ping 通,實驗現象成功(由於PC2是windows 7 簡體中文版本,故ping結果是中文方式顯示的) 測試步驟:開始-運行-cmd
C:\>ping 172.16.0.1
正在 Ping 172.16.0.1 具備 32 字節的數據:
來自 172.16.0.1 的回覆: 字節=32 時間=1ms TTL=255
來自 172.16.0.1 的回覆: 字節=32 時間=1ms TTL=255
來自 172.16.0.1 的回覆: 字節=32 時間=1ms TTL=255
來自 172.16.0.1 的回覆: 字節=32 時間=1ms TTL=255
172.16.0.1 的 Ping 統計信息:
數據包: 已發送 = 4,已接收 = 4,丟失 = 0 (0% 丟失),
往返行程的估計時間(以毫秒爲單位):
最短 = 1ms,最長 = 1ms,平均 = 1ms
Control-C
^C
C:\> ping 12.0.0.2
正在 Ping 12.0.0.2 具備 32 字節的數據:
來自 12.0.0.2 的回覆: 字節=32 時間=2ms TTL=255
來自 12.0.0.2 的回覆: 字節=32 時間=2ms TTL=255
來自 12.0.0.2 的回覆: 字節=32 時間=2ms TTL=255
來自 12.0.0.2 的回覆: 字節=32 時間=2ms TTL=255
12.0.0.2 的 Ping 統計信息:
數據包: 已發送 = 4,已接收 = 4,丟失 = 0 (0% 丟失),
往返行程的估計時間(以毫秒爲單位):
最短 = 2ms,最長 = 2ms,平均 = 2ms
Control-C
^C
C:\> ping 12.0.0.1
正在 Ping 12.0.0.1 具備 32 字節的數據:
來自 12.0.0.1 的回覆: 字節=32 時間=1ms TTL=254
來自 12.0.0.1 的回覆: 字節=32 時間=1ms TTL=254
來自 12.0.0.1 的回覆: 字節=32 時間=1ms TTL=254
來自 12.0.0.1 的回覆: 字節=32 時間=1ms TTL=254
12.0.0.1 的 Ping 統計信息:
數據包: 已發送 = 4,已接收 = 4,丟失 = 0 (0% 丟失),
往返行程的估計時間(以毫秒爲單位):
最短 = 1ms,最長 = 1ms,平均 = 1ms
Control-C
^C
C:\>ping 192.168.0.1
正在 Ping 192.168.0.1 具備 32 字節的數據:
來自 192.168.0.1 的回覆: 字節=32 時間=1ms TTL=254
來自 192.168.0.1 的回覆: 字節=32 時間=1ms TTL=254
來自 192.168.0.1 的回覆: 字節=32 時間=1ms TTL=254
來自 192.168.0.1 的回覆: 字節=32 時間=1ms TTL=254
192.168.0.1 的 Ping 統計信息:
數據包: 已發送 = 4,已接收 = 4,丟失 = 0 (0% 丟失),
往返行程的估計時間(以毫秒爲單位):
最短 = 1ms,最長 = 1ms,平均 = 1ms
Control-C
^C
C:\> ping 192.168.0.200
正在 Ping 192.168.0.200 具備 32 字節的數據:
Control-C
^C
C:\>ping 192.168.0.100
正在 Ping 192.168.0.100 具備 32 字節的數據:
來自 192.168.0.100 的回覆: 字節=32 時間=1ms TTL=62
來自 192.168.0.100 的回覆: 字節=32 時間=1ms TTL=62
來自 192.168.0.100 的回覆: 字節=32 時間=1ms TTL=62
來自 192.168.0.100 的回覆: 字節=32 時間=1ms TTL=62
192.168.0.100 的 Ping 統計信息:
數據包: 已發送 = 4 ,已接收 =4 ,丟失 = 0 (0% 丟失)
往返行程的估計時間( 以毫秒爲單位):
最短 = 1ms ,最長 = 1ms ,平均 = 1ms
Control-C
^C
相關文章
相關標籤/搜索