POJ2752(next原理理解)

Seek the Name, Seek the Fame
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 15536   Accepted: 7862

Descriptionapp

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father's name and the mother's name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

Inputspa

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Outputcode

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Inputblog

ababcababababcabab
aaaaa

Sample Outputip

2 4 9 18
1 2 3 4 5
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN=400005;
char s[MAXN];
int next[MAXN];
int len;
void getnext()
{
    int i=0,k=-1;
    next[0]=-1;
    while(i<len)
    {
        if(k==-1||s[i]==s[k])
        {
            i++;
            k++;
            next[i]=k;
        }
        else    k=next[k];
    }
}
int num[MAXN],cnt;
int main()
{
    while(gets(s))
    {
        cnt=0;
        len=strlen(s);
        getnext();
        int k=len;
        num[cnt++]=len;
        while(next[k]!=0)
        {
            k=next[k];
            num[cnt++]=k;
        }
        for(int i=cnt-1;i>0;i--)
            printf("%d ",num[i]);
        printf("%d\n",num[0]);
    }
    
    return 0;
}
相關文章
相關標籤/搜索