POJ1852

題目連接:http://poj.org/problem?id=1852ios

題目表述:app

Ants
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 33151   Accepted: 12362

Descriptionspa

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Inputcode

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Outputblog

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.

Sample Inputip

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Outputci

4 8
38 207

Sourceget

思路:即求出最大值與最小值便可,最小值就是每一個螞蟻離某一端取最近的,而後在每一個最近中選擇時間須要最多的那個螞蟻。注意每一個螞蟻是同時進行運動的。
要求時間最大值時,題目描述說,當兩個螞蟻相遇時,只能各自掉頭返回,咱們在求最大值時,能夠把螞蟻視做無視相遇,照常穿過,一樣也能夠求出最大值,即取所需時間最多的那個螞蟻的時間便可。
 
代碼以下:
#include<iostream>
#include<cmath>
using namespace std;

int main()
{
    int n,l,t;
    cin >> t;
    while(t--)
    {
        int min1 = 0,max1 = 0,x;
        cin >> l >> n;
        for(int i = 0;i < n;i++)
        {
            cin >> x;
            if(x <= l / 2)
            {
                min1 = max(min1,x);
                max1 = max(max1,l - x);
            }
            else
            {
                min1 = max(min1,l - x);
                max1 = max(max1,x);
            }
        }
        cout << min1 << " " << max1 << endl;
    }
    return 0;
}
相關文章
相關標籤/搜索