--R1--------R2--------R3---
RIPV1 RIPV1 RIPV2
R1#show running-config
!
interface Loopback0
ip address 10.0.0.1 255.0.0.0
!
interface Serial1/1
ip address 20.0.0.1 255.0.0.0
serial restart-delay 0
!
router rip
network 10.0.0.0
network 20.0.0.0
R2#show running-config
!
interface Serial1/0
ip address 20.0.0.2 255.0.0.0
serial restart-delay 0
!
interface Serial1/1
ip address 30.0.0.1 255.0.0.0
serial restart-delay 0
!
router rip
network 20.0.0.0
network 30.0.0.0
R3#show running-config
interface Loopback0
ip address 40.0.0.1 255.0.0.0
!
interface Serial1/0
ip address 30.0.0.2 255.0.0.0
ip rip send version 1 2
ip rip receive version 1 2
serial restart-delay 0
!
router rip
version 2
network 30.0.0.0
network 40.0.0.0
!
R1#show ip rou
Gateway of last resort is not set
C 20.0.0.0/8 is directly connected, Serial1/1
R 40.0.0.0/8 [120/2] via 20.0.0.2, 00:00:03, Serial1/1
C 10.0.0.0/8 is directly connected, Loopback0
R 30.0.0.0/8 [120/1] via 20.0.0.2, 00:00:03, Serial1/1
R2#show ip route
Gateway of last resort is not set
C 20.0.0.0/8 is directly connected, Serial1/0
R 40.0.0.0/8 [120/1] via 30.0.0.2, 00:00:07, Serial1/1
R 10.0.0.0/8 [120/1] via 20.0.0.1, 00:00:12, Serial1/0
C 30.0.0.0/8 is directly connected, Serial1/1
R3#show ip rou
Gateway of last resort is not set
R 20.0.0.0/8 [120/1] via 30.0.0.1, 00:00:00, Serial1/0 C 40.0.0.0/8 is directly connected, Loopback0 R 10.0.0.0/8 [120/2] via 30.0.0.1, 00:00:00, Serial1/0 C 30.0.0.0/8 is directly connected, Serial1/0