poj 1504 Adding Reversed Numbers

Adding Reversed Numbersjava

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 18730   Accepted: 10090

Descriptiongit

    The Antique Comedians of Malidinesia prefer comedies to tragedies. Unfortunately, most of the ancient plays are tragedies. Therefore the dramatic advisor of ACM has decided to transfigure some tragedies into comedies. Obviously, this work is very hard because the basic sense of the play must be kept intact, although all the things change to their opposites. For example the numbers: if any number appears in the tragedy, it must be converted to its reversed form before being accepted into the comedy play. 

    Reversed number is a number written in arabic numerals but the order of digits is reversed. The first digit becomes last and vice versa. For example, if the main hero had 1245 strawberries in the tragedy, he has 5421 of them now. Note that all the leading zeros are omitted. That means if the number ends with a zero, the zero is lost by reversing (e.g. 1200 gives 21). Also note that the reversed number never has any trailing zeros. 

    ACM needs to calculate with reversed numbers. Your task is to add two reversed numbers and output their reversed sum. Of course, the result is not unique because any particular number is a reversed form of several numbers (e.g. 21 could be 12, 120 or 1200 before reversing). Thus we must assume that no zeros were lost by reversing (e.g. assume that the original number was 12).app

Inputide

    The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly one line with two positive integers separated by space. These are the reversed numbers you are to add.ui

Outputthis

    For each case, print exactly one line containing only one integer - the reversed sum of two reversed numbers. Omit any leading zeros in the output.spa

Sample Inputcode

3
24 1
4358 754
305 794

Sample Outputorm

34
1998
1

題目大意:將給定的兩個數反轉,相加,再反轉,而後輸出,前置0忽略。好比305和794, 反轉後爲503和497,相加獲得1000,反轉後爲0001, 也就是1.ip

Solution: 一直覺得oj上的題很高大上,直到碰見這個題。

import java.io.BufferedReader;
import java.io.InputStreamReader;

public class Main {
    public static void main(String[] args) throws Exception {
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
        int n = Integer.parseInt(br.readLine());
        while (n-- > 0) {
            String[] s = br.readLine().split("\\s+");
            System.out.println(Integer.parseInt(new StringBuilder(Integer.parseInt(new StringBuilder(s[0]).reverse().toString()) + Integer.parseInt(new StringBuilder(s[1]).reverse().toString()) + "").reverse().toString()));
        }
        br.close();
    }
}
相關文章
相關標籤/搜索