UVa 101-The Blocks Problem

問題描述】ios

Many areas of Computer Science use simple, abstract domains for both analytical and empirical studies. For example, an early AI study of planning and robotics (STRIPS) used a block world in which a robot arm performed tasks involving the manipulation of blocks. In this problem you will model a simple block world under certain rules and constraints. Rather than determine how to achieve a specified state, you will ``program'' a robotic arm to respond to a limited set of commands.app

The problem is to parse a series of commands that instruct a robot arm in how to manipulate blocks that lie on a flat table. Initially there are n blocks on the table (numbered from 0 to n-1) with block bi adjacent to block bi+1 for all  as shown in the diagram below:dom

The valid commands for the robot arm that manipulates blocks are:ui

  • move a onto b where a and b are block numbers, puts block a onto block b after returning any blocks that are stacked on top of blocks a and b to their initial positions.this

  • move a over b where a and b are block numbers, puts block a onto the top of the stack containing block b, after returning any blocks that are stacked on top of block a to their initial positions.spa

  • pile a onto b where a and b are block numbers, moves the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto block b. All blocks on top of block b are moved to their initial positions prior to the pile taking place. The blocks stacked above block a retain their order when moved.code

  • pile a over b where a and b are block numbers, puts the pile of blocks consisting of block a, and any blocks that are stacked above block a, onto the top of the stack containing block b. The blocks stacked above block a retain their original order when moved.orm

  • quit terminates manipulations in the block world.ip

Any command in which a = b or in which a and b are in the same stack of blocks is an illegal command. All illegal commands should be ignored and should have no affect on the configuration of blocks.ci

Input 

The input begins with an integer n on a line by itself representing the number of blocks in the block world. You may assume that 0 <n < 25. The number of blocks is followed by a sequence of block commands, one command per line. Your program should process all commands until the quit command is encountered. You may assume that all commands will be of the form specified above. There will be no syntactically incorrect commands.

Output 

The output should consist of the final state of the blocks world. Each original block position numbered i (  where n is the number of blocks) should appear followed immediately by a colon. If there is at least a block on it, the colon must be followed by one space, followed by a list of blocks that appear stacked in that position with each block number separated from other block numbers by a space. Don't put any trailing spaces on a line. There should be one line of output for each block position (i.e., n lines of output where n is the integer on the first line of input).

Sample Input 

10
move 9 onto 1
move 8 over 1
move 7 over 1
move 6 over 1
pile 8 over 6
pile 8 over 5
move 2 over 1
move 4 over 9
quit

Sample Output 

0: 0
 1: 1 9 2 4
 2:
 3: 3
 4:
 5: 5 8 7 6
 6:
 7:
 8:
 9:


【解題思路

    空。   


【具體實現

#include <iostream>  
#include <cstdlib>  
#include <cstdio>   

using namespace std;

int place[25];
int stack[25][25];
int top[25];

//將a上面的放回原位   
void init_place(int a)
{
	int block, id = place[a];
	while (stack[id][top[id]] != a) {
		block = stack[id][top[id] --];
		place[block] = block;
		stack[block][++top[block]] = block;
	}
}

//將a和上面的全都移動到b上  
int  temp[25];
void pile_a_to_b(int a, int b)
{
	int topt = -1, id = place[a], ID = place[b];
	//先將a上面的逆序存入temp   
	while (stack[id][top[id]] != a)
		temp[++topt] = stack[id][top[id] --];
	//再存入a  
	place[a] = ID;
	stack[ID][++top[ID]] = a;
	top[id] --;
	//最後將temp裏面的逆序存入b   
	while (topt >= 0) {
		place[temp[topt]] = ID;
		stack[ID][++top[ID]] = temp[topt--];
	}
}

int main()
{
	int  n, a, b;
	char oper[5], type[5];
	while (~scanf("%d", &n)) {
		for (int i = 0; i < n; ++i) {
			stack[i][0] = i;
			place[i] = i;
			top[i] = 0;
		}
		while (scanf("%s", oper) && oper[0] != 'q') {
			scanf("%d%s%d", &a, type, &b);

			//若是ab在同一堆,不處理   
			if (place[a] == place[b])
				continue;

			//若是是move先把a上面的還原   
			if (oper[0] == 'm')
				init_place(a);

			//若是是onto先把b上面的還原   
			if (type[1] == 'n')
				init_place(b);

			//把A堆放在B堆上    
			pile_a_to_b(a, b);
		}

		for (int i = 0; i < n; ++i) {
			printf("%d:", i);
			int now = 0;
			while (now <= top[i])
				printf(" %d", stack[i][now++]);
			printf("\n");
		}
	}
	return 0;
}


【額外補充

   空。

相關文章
相關標籤/搜索