11572 - Unique Snowflakes(貪心,兩指針滑動保存子段最大長度)

 Emily the entrepreneur has a cool business idea: packaging and selling snowflakes. She has devised a machine that captures snowflakes as they fall, and serializes them into a stream of snowflakes that flow, one by one, into a package. Once the package is full, it is closed and shipped to be sold. The marketing motto for the company is 「bags of uniqueness.」 To live up to the motto, every snowflake in a package must be different from the others. Unfortunately, this is easier said than done, because in reality, many of the snowflakes flowing through the machine are identical. Emily would like to know the size of the largest possible package of unique snowflakes that can be created. The machine can start filling the package at any time, but once it starts, all snowflakes flowing from the machine must go into the package until the package is completed and sealed. The package can be completed and sealed before all of the snowflakes have flowed out of the machine.
Input
The first line of input contains one integer specifying the number of test cases to follow. Each test case begins with a line containing an integer n, the number of snowflakes processed by the machine. The following n lines each contain an integer (in the range 0 to 109, inclusive) uniquely identifying a snowflake. Two snowflakes are identified by the same integer if and only if they are identical. The input will contain no more than one million total snowflakes.
Output
For each test case output a line containing single integer, the maximum number of unique snowflakes that can be in a package.
Sample Input
1 5 1 2 3 2 1
Sample Output
3ios

 

分析:ide

從一個有n個數的序列中,找到一個最大的子段(連續的),使得這個最大子段中沒有重複元素,輸出最大子段的長度。this

注意:序列是不連續的,子段必須是連續的idea

作法:spa

對於該類段查找問題能夠採用經典的滑動窗口方法,即維護一個窗口,窗口的左右邊界用兩個變量L,R表明,先增長R直到出現重複數字,再增長L,再增長R,直到R達到ncode

貼張圖形象得一批~blog

set好用!ip

code:ci

#include<stdio.h>
#include <iostream>
#include <math.h>
#include <queue>
#include<set>
using namespace std;
#define max_v 1000005
int a[max_v];
int main()
{
    set<int> s;
    int t,n;
    cin>>t;
    while(t--)
    {
        cin>>n;
        for(int i=0;i<n;i++)
            cin>>a[i];
        s.clear();
        int left=0,right=0,ans=0;
        while(right<n)
        {
            while(right<n&&!s.count(a[right]))
            {
                s.insert(a[right++]);
            }
            ans=max(ans,right-left);
            s.erase(a[left++]);
        }
        cout<<ans<<endl;
    }
    return 0;
}
相關文章
相關標籤/搜索